Bitcoin network

Can someone please help me.

I installed bisq version 1.9.12 on a brand new computer about 10 days ago. My problem is that Bisq doesn’t connect to the Bitcoin network.
From what I can see, I have connection to the Bisq network peers and my local node is in consensus with the DAO network,
At startup, my computer seems to connect to TOR and creates a TOR node.
I use Windows Defender as Antivirus. I have allowed bisq.exe in Windows Defender.

The details of my computer are:
Windows 11 Home
Processor 13th Gen Intel(R) Core™ i7-1360P 2.20 GHz
RAM 16,0 GB (15,7 GB)
System 64-bit operating system, x64-based processor

I feel I have tried everything to connect to the Bitcoin network but nothing changes - Bisq just can’t find the Bitcoin network, This is what I have tried:

  • I have deleted the SPV file and resynced (when I do this, Bisq gets stuck in the startup screen)
  • I have uninstalled Bisq and installed again
  • I have deleted bisq.properties file
  • I have deleted all the files under btc_mainnet and restarted the computer
  • I have tried using custom Bitcoin Core nodes (copied from my old computer where Bisq is working)
  • I have tried disabling Windows Defender

Is there anything else at all that I can try, or will I not be able to use Bisq on my new computer?

Try deleting the old Tor files.

Settings, Network Info, Open Tor Settings, Delete outdated Tor files

Is this a new installation? Do you have trades in progress?

I’ve already tried deleting Tor.
When it starts upp it looks like Tor is connecting normally. And I have a connection to the Bisq network.
Yes, it’s a new installation.
I have no trades in progress or no funds there. I have not added any accounts either.

This is what it looks like. I have connection to bisq but not bitcoin network.

If I “Delete SPV file and resync”, then I have another problem, because then bisq won’t load at all. It just just gets stuck at the startup screen.

Do you have any other virus / malware programmes that could be interfering with the connection to the Bisq network?

Is it possible that you have installed bitcoin core on your system, but you’re not really paying attention to it? probaby bisq tried to connect to it, and fails since you wouldn’t obviously have set it to work with bisq.

I think I might have solved my problem.
I disabled the box “Use Tor for Bitcoin network”.
Suddenly Bisq started to connect to the Bitcoin network.

However, If I activate the box “Use Tor for Bitcoin network”, then I don’t have a connection to the Bitcoin network.

Is it a problem that I can’t use Tor?

you can use Tor for sure, since you wouldn’t be able to connect to the bisq p2p network that only runs on Tor… so you are connecting to default nodes and didn’t set a custom node’s address under Settings > Network?

These are my settings now.
If I click “Use Tor for Bitcoin network” it doesn’t work.

that is very strange, but I reckon this is what it is… there are no big downsides to not using tor for bitcoin network, except your ISP knowing you are connecting to bitcoin nodes, rather than just “tor”.
Since you already tried refreshing your tor files, there is nothing more that comes to mind to suggest