Cannot connect

Cannot correct due to:

org.bitcoinj.wallet.UnreadableWalletException: Could not connect 1ff8c27aec4d20d7767f3d3026456675081b4b515db65df667155ec23fc719f2 to b6a65c444653a14f4118e53d304270e8cfe973304ac38a387ea58040181e9db3

I have no idea what to do. Any suggetion? Tried reinstalling, that is as far as my computer knowledge goes. Thank you

Hi @saveus thanks for posting.

Normally that means your wallet is corrupted. An SPV resync should fix it. Here are the instructions how to do an SPV resync: Resyncing SPV file - Bisq Wiki

Let me know how you get on.

1 Like

I found the bisq.spvchain file only in my BISQ backup archive, not in the current BISQ location. Anyway, I deleted it, but the same error is still ocurring.
I have bisq intalled on disk D:
I fount the archive in a backup in disk D: , but also in a file that was in C: (I don´t even know how it ended up there, it was inside an user/roaming file) I’ve deleted both, but it’s still not working

This is where Bisq directories are: Data directory - Bisq Wiki
For windows it must be: $home\AppData\Roaming\Bisq
Deleting the file in a backup won’t affect what happens on the directory data that your client is using.

1 Like

For windows it must be: $home\AppData\Roaming\Bisq

I found it also. Inside this file there’s no bisq.spvchain file =//
bisq_BSQ.wallet and bisq_BTC.wallet (also a backup file)

I guess I’ve already deleted there too

Any other idea? I just want my sats back =/

The SPV chain is in:


The file is called bisq.spvchain

You should be able to delete this and restart Bisq (always good to make a backup first)

One restarted it will resync the wallet, might take a while but you will see a status bar, and then once complete you will be able to access Biaq.

1 Like

It’s in local disk C:
my BISQ is installed in D: , may it be the problem?

SS with the file, already deleted.

1 Like

If the file is already deleted it should be created again when you restart Bisq. You should see a status indicator on restarting going from 0-100%.

1 Like

Anyone? I don´t gave much there, but I´d like to take my sats out. I can pay if anyone is ablr to help me solve


All I get is this after the error window

And after that, something about bridges, that won’t work also

That’s a connectivity error that could happen even if the previous error didn’t.
“Apagar ficheiros de tor…” might help to solve this connectivity issue.

1 Like

Won’t work =/

are you using your own bitcoin node?
because if that’s the case, that means you cannot connect to it, and rather need to restore network provided bitcoin nodes, as described in troubleshooting section of Connecting to your own Bitcoin node - Bisq Wiki

1 Like

I had btc node installed a while ago, but I’ve uninstalled it. (BISQ was working after that, and suddenly this error ocurred). May it be the problem? Is there anything I can do about the node?
I mean, i’ve uninstalled it, but maybe there’s something remaining there that is causing this bug

if you uninstalled the node, but didn’t explicitly tell bisq to use default nodes, this could cause the issue. This is why I suggest following the troubleshooting in the linked article to see if it solves anything.

As an alternative, you can try starting Bisq with a fresh data directory, by renaming the original data directory from Bisqto Bisq.ori and restarting the application, if you get a bitcoin connection there is a hacky way to restore your old data directory into the new one

1 Like

troubleshooting has info about mac and linux, but I use windows =(

I tried the renaming, BISQ is now running a new acc. If I backup my old wallet, will it bug again? Any idea?

(thanks in advance, I guess the first step is fine)

Thank for your help, I can access my wallet now. It’s not working 100%, but at least I can open it.

You need to wait until the download of missing Bitcoin blocks is complete.

Now I have this problem. Already tried deleting SPV, still same error

Do you see a status of the missing blocks on the bottom left of Bisq? If you have not run Bisq for a while it needs to download each block. Should show a percentage of where it is up to, and even the block it is up to.

1 Like