Deactivating open offer xxxxxxx due to mempool validation

I made a testing offer, very unattractive, on a node I am working to debug with the Whonix team. I notice that when I move the “Status” slider to “on” it will turn “off” after about 1 minute.

The error is: Deactivating open offer xxxxxxx due to mempool validation

Can anyone explain what this means so I can debug?

EDIT: found "Deactivating open offer due to mempool validation" does not produce any GUI explanation · Issue #6127 · bisq-network/bisq · GitHub.

I will delete and re-sync SPV

1 Like

verify that your maker fee tx exists on mempool: if it does, you are advised to do a spv resync, and if it doesn’t, the offer is null and you can delete it (and still need to do a spv resync because bisq probably tried to use a utxo which wasn’t there anymore)

What do you mean by “exists on mempool”? You mentioned that phrase but didn’t actually say how to test. But anyway, before you wrote back I solved the issue myself. Note the EDIT in my post. re-syncing fixed it (the second time)

existing on mempool, for a transactions, means that searching for its id for example on mempool will show it, rather than saying it’s not found

This is still an empty statement. “searching for its id for example on mempool” may have semantic value to you but until you explain what to do, it will not have semantic value to me.

And semantic value is what the question “what do you mean” is aimed at achieving.

If I type “bisq mempool how search” I get this page:

But that doesn’t tie in with what you said in any obvious way.

I also get this:

Is that where to search? I do not have a transaction ID anymore to search for so I don’t know. But if that is the answer, wouldn’t it have been much more helpful and efficient to type “search for your maker fee tx, which you find in Bisq at X > Y > Z and type it into

I think it would.

Anyway as I said in my orignal post, I already found the solution to this and fixed it with an SPV resync.

I am now working with the Whonix devs to make Bisq work on Whonix, so I am much more interested in

Because currently Bisq does not work reliably with Whonix, Tails, or Tor. Yikes!