Remove offer failed

When clicking on the “Remove offer” link for an open offer a Warning box appears with the message Remove offer failed: Remove offer failed. I’ve tried installing the most up-to-date version of Bisqu and the error persists. Trying to get the BTC from this offer out of the Reserved wallet and back into my Available balance. Any suggestions?

I have not seen that error before. Can you post a screen shot

i believe the problem is arising due to an inappropriate restore of my bisq data. the original computer that bisq was running on, and from which the now undeletable offer was published, died. unfortunately i had never created a proper backup prior to the computer dying. however, i was able to grab the bisq files from the computer’s hard drive, copy them onto a new computer and then install bisq on that new computer and tried to direct the new installation to use the old computer’s files. i honestly don’t remember exactly how i did this as it was months ago, but i’m revisiting the issue now. my transaction history updated and this offer is still open, but again it’s uneditable and undeletable…

Ok, I would suggest the following:

  1. Check the maker transaction to see if there are any funds allocated to the trade. To do this click on the (i) next to the trade. Then click the maker transaction and see if their is a balance in the bitcoin output. If you are not sure how to do this please post the maker transaction here or send me a DM for more privacy.

  2. Make a backup of your Bisq application directory Backing up application data - Bisq Wiki

  3. Once this is done it will be ok to manually remove the offer.

Do do this you can follow the instructions below:

A. Check you do not have any other offers in your portfolio in ‘Open offers’
B. In your Bisq app go to Account > Backup and click the ‘Open Directory’ button
C. Once you directory is open go the file ‘db’ found in Bisq\btc_mainnet\db
D. Close Bisq
E. Delete the ‘OpenOffers’ file from the ‘db’ folder
7. Restart Bisq

The trade will now be removed from your Bisq ‘Open Offers’