V1.9.9 update fail

Hi all,

Just opened Bisq and followed the prompts to update to v1.9.9 but it keeps failing.
I then followed the link to the Bisq site and downloaded the files manually, but there is an error with the verification:

Is this what is outlined on the github page where it says:

We removed the developer code signing because of the same reason as with Apple.
For Windows you just have to ignore the warning after you have verified the installation file yourself and proceed with the installation.


I also found this post and tried with the public key christoph provided, but that didn’t work either.

So, do I really just ignore the lack of verification and install the update anyway?, or is there something I’m missing?

E: am on Win10


Validation of the key should work with alejandrogarcia’s key for v1.9.9

Well, as you can see from the attached photo, it hasn’t, which is why I’ve posted asking for advice, so my question still stands.

Not very familiar with Windows. Maybe you are trying to verify the key instead of the binary?

Thanks for the reply, I had already seen and followed the instructions in that link before posting here, and the problem isn’t that I’m trying to verify the wrong thing.

I even downloaded Gpg4win which the wiki mentions, to try in the unlikely case it was the GPG4usb I was using that was causing the problem, but the verification fails on Kleopatra, too, citing “bad signature” from Alejandro Garcia.

I played around a little again this morning trying to figure it out, and ended up setting up a new key for myself and tried with that from scratch and suddenly it worked, which makes the whole thing even more frustrating, but I guess it’s done now, so that doesn’t really matter (to me the end user, though it probably should matter to the people releasing these files since I’m not the only one who has had the same, or at least very similar, issue).