Bisq stuck connecting to TOR at step 1/4

Hello everyone. I am at a loss on how to connect and restore my bisq on my Windows 11 laptop. I am stuck on step 1/4 and it cannot connect to TOR (with or without bridges). I have tried many times and even restarted my PC. And I have waited 10 - 15 minutes each time with no luck. I never had to wait for it to load this long, it usually takes a minute or less to connect (with obfs4 bridge). I have done past trades on bisq, but I cannot get it working for the past 3 days now.

Also, I have read and verified that I have done all these steps Troubleshooting network issues - Bisq Wiki I have done all of them, but it still does not work. I specifically made exceptions in my anti-virus and firewall for bisq and all the tor-related stuff. TOR is not banned in my country and it works on my mobile. I use a well-known VPN service in case you need that info to help me. I have also tried deleting file and running bisq again, but it did not work.

The reason why bisq had stopped working in the first place is that my anti-virus software had stopped bisq (and TOR) from running and quarantined it and said it was an attack on my PC, but it wasn’t. I have used bisq months before and I never had Bitdefender stop it.

If anyone has any insight on this or any ideas on how to fix it, please let me know. Thank you so much.

Are you getting any error messages.

Sometimes the issue could be your wallet i is out of sync.

Try doing an SPV resync

  • I recommend you do a back up first.
  • Then delete the SPV file. it is called bisq.spvchain and found in C:\Users[your-user-name]\AppData\Roaming\Bisq\btc_mainnet\wallet
  • Restart Bisq and then hopefully you will be able to connect

No, I am not getting any error messages that I see. All I see is “1/4 Connecting to Tor network…”

Also, I tried doing an SPV resync by creating a backup and then deleting bisq.spvchain, but it did not work. I just get the same screen as before (the one I attached above).

Are you able to access Tor from your computer using the Tor browser?

Yes, I am able to connect to the network, but when I search for something, nothing loads. However, I must stress that it was like this when Bisq WAS working. So that cannot be it.

I just found out: I let Bisq run for 30 - 45 mins on the loading screen, and I saw this:

However, I don’t see anything that could block the Bisq connection. I let Bisq through my firewall already.

I would try connecting to Bisq using another internet connection (eg using your phone as a hotspot).

If that works you know the issue is your current internet connection.

Also check out:

Yes, I have checked and made sure that all those are done. I have posted that link in my original post. You might not have seen it since this forum formats links weirdly, but it’s there. None of those solutions work for me.

Have you tried connecting with another internet connection?

No, I haven’t. The main reason why Bisq broke in the first place is because my anti-virus (Bitdefender) saw it as an attack on my PC, and it quarantined Bisq and all the Tor files. I had to restore my files from Bitdefender and maybe I didn’t restore it 100%. I am not sure what I might be missing. Although, I did uninstall my original Bisq and downloaded a new one from the website. However, the new Bisq download didn’t work either. Same result, same anti-virus exceptions for Bisq and Tor. So I reinstalled my original Bisq files and now I am here.

Hello again. I have tried using a mobile hotspot today and running Bisq while connected to it, but it did not work either. Not sure what is happening…

Sounds like Bisq might be missing some files to start.

Have you tired pausing your Bitdefender then reinstalling Bisq from Bisq Downloads ‹ Bisq - A decentralized bitcoin exchange network

Hopefully that will restore the missing files.

Yup! I installed it again and turned off my anti-virus and it connected! Thank goodness. Thank you so much!

1 Like

Glad it is fixed