1 BTC (edit: now ~3.25 BTC) bounty for Bitsquare on raspberry pi

pteron: I just ran your script and I ended up with the same black only application that I got myself and the screen froze. Also had to create a folder manually (/root/.local/share/Bitsquare) (but that may have been because I ran it as root).

After amustafa’s memory fix the application did launch, filling up the entire screen. I got this error:

You have probably the wrong version installed for the architecture of your computer. your computers architecture is: 64. The Bitsquare binary you installed is: 32. Please shut down and re-install the correct version (64).

It also failed to connect to Tor … then I got this error:

The application could not startup after 4 minutes. You still did not get connected to the P2P network. That can happen sometimes when you got an unstable Tor path. You can wait longer or try to restart.

Log’s here: http://pastebin.com/raw/H8yWyCAt

Seepy: The .deb file did not work for me, but it’s also not as safe to run binaries as it is compiling from source yourself. You never really know with 100% certainty that the binaries are the same as the source code which you can inspect yourself.

I’ll try amustafa’s script now.

64bit? I thought only the 3 would run 64 bit…

The script needs updating for 64 bit.

Also, you installed as root rather than pi. Need to catch that.

I thought so too… But to be fair, the error says “probably”, could be something else wrong. AFAIK Raspberry Pi 2 Model B is for 32-bit.

Installing as root was a mistake btw.

Edit: re-ran as pi, gets to the terms of agreement screen, then everything just freezes.

I ran amustafa’s script, got some errors, log from terminal

Got everything running on my Pi 2, I have to leave soon though, so I won’t be able to finish the script before tomorrow.

Has anyone gotten this working completely yet? If not I’ll get my script cleaned up and posted.

None of the solutions posted yet has been fully working, but they’re almost there.

Hi @pteron,
the Oracle java version does nto need javaFx as it is included in the JDK. ONly for OpenJDK you need extra OpenJfx.
A headless version does not work with the application. The seed node would work but that is useless for that use case.

EDIT: Did not read the follow up posts. Dont have experience with the ARM JDK, just used the standard JDK and there JFX is included.

I re-create a new script because i missed all prerequisites

You can find the new script with more file here: Github

Added an issue for the architecture: https://github.com/bitsquare/bitsquare/issues/491

The warning popup regarding wrong architecture might be wrong for RPi. You can see the detail logs when changing Level.WARN to Level.INFO in the io.bitsquare.app.Log class at line 84. Though need a forked version with that code change.
I will add a command line arg for chaning the log level for the next version. But it is just a info popup not preventing to run the app.

The error comes from the Tor library (line93):

Seems that it does not recognize RPi. A version with loglevel to debug or info might help here as well.

Do you want this to be rpi1-3 or is just 3 ok?

I only have rpi2b, so that’s what I’d like. Of course I’m sure others will be pleased if you also offer something working with the other versions, but with rpi2b I can validate the bounty.

Here’s my simple script, some stuff is needed from testing repo, hope it works. Run as the regular desktop user.


I’ll do another clean test in the morning to make sure it works completely and add more to it.

@TheKoziTwo looks like the TOR library can’t yet run on rasp pi. Once this is fixed pretty much any of the scripts will work.

(Plus your original post says compiles and installs… doesn’t actually say run!)

I don’t know about that. Raspberry PI is super popular as a Tor Router / Relay (just google: raspberry pi Tor). But it could be an issue with bitsquare itself.

The definition of install according to dictionary is:

Place or fix (equipment or machinery) in position ready for use:

  • we’re planning to install a new shower

I think “ready for use” is the key here. If it can’t be run, it’s not ready for use. The whole reason I put up this bounty in the first place is so that I can start market making on bitsquare using rpi, so a non-working installation doesn’t help me much.

That said, I can also sympathize with the bounty hunters who has put in a lot of effort here and I do intend to give out the bounty to the closest solution if it turns out it really cannot be done.

I’m not convinced of that yet, so let’s wait a little longer to see if someone can come up with the final solution to this before we give out the bounty.

I’m think I’m pretty close to getting it all up and running.

1 Like

Is installing Arch Linux (or Manjaro if you want something simpler to install) on the raspberry pi an option ? So you could use the AUR.

Of course, I was being tongue-in-cheek!

The library I mentioned is the java TOR library

Update: The fix for this last bug seems to be alluding me. I need to get some sleep but I’ll be back on it in a few hours.

I have a question about the bounty rules. Do partial bounties get divided up or is it a winner take all kind of thing?