1 BTC (edit: now ~3.25 BTC) bounty for Bitsquare on raspberry pi


I am TheKoziTwo on bitcointalk. Early adopter of bitcoin, owner of the first Monero exchange.


I am a big fan of the bitsquare project and want to support it by providing market liquidity. I would like to do so by keeping my raspberry online 24/7 and run bitsquare on it. I tried to install it myself, but it did not launch properly (black screen) when I tried and don’t have time to mess around with it right now, also I want a script doing it all automatically, so therefore I offer a bounty.

The rasbian jessie image can be downloaded from: https://www.raspberrypi.org/downloads/raspbian/

The first person who can post a fully working bash script that compiles and installs bitsquare (and all its dependencies) on Raspbian Jessie will be rewarded 0.75 BTC. Additional 0.25 BTC will be rewarded if the script can be run to update to a new release automatically.

E.g all needed to install bitsquare on raspbian should be a command such as:

and to upgrade to latest version
./bitsquare.sh --update

Build docs for bitsquare

If the person who post the script does not want the bounty I will donate the funds to bitsquare development.

I can pay the bounty in Monero for those who prefer that.



Wow. Gives some hope for humanity!
I match your bounty.
Please communicate via this forum when you are satisfied with the script(s) and then we can communicate so I know to which address the bounty should be sent. I do not use Monero. I would need some type of confirmation that it works but I don’t expect this to be much of a problem.

1 Like

Thanks for matching the bounty! I’ll request the script and payment address to be posted in this topic.

I just noticed there’s also an additional bounty of 0.25 BTC offered by reddit user avgeca here: https://www.reddit.com/r/Monero/comments/4nj0v4/1btc_or_xmr_equivalent_bounty_for_raspberry/d44o0zp

I have tested it on my very old raspberry pi, but RAM is not enough.
Please test is on a modern one :slight_smile:

Unfortunately the script did not work fully for me. Getting errors: http://pastebin.com/raw/BqrenYZg

I’m using Raspberry Pi 2 Model B with Rasbian Jessie 4.4

I add 500 Monero to the bounty. Same procedure regarding acceptance as @mepistol described.


I just added a general bounty rule set and overview:
Feel free to follow that (or ignore :-)).

I have set up a Github issue with a link to this thread.

Frederic, looking at the code, it seems you have not included the prerequisites in the script? Please include those. I will test it after.

just wanted to confirm my 0.25btc (or monero equivalent) bounty contribution on here. let me know where to send it if you find a script satisfying. I think with the bounty right now, we can expect people to give us something nice :wink:


The issue with the https://github.com/metabit/bitsquare-on-raspberry-pi script is that the latest version of java from Oracle does not contain the javafx library.

Here is the updated script with a community compiled openjfx overlaid - a possible security risk but compiling openjfx is a pain in the arse https://github.com/pteron/bitsquare-on-raspberry-pi

It compiles on a rasp pi 2 but I get an error on startup - my pi is running headless, not sure if this has anything to do with it. Will investigate further - the issue is a failure to update the java alternative.

run using /opt/jdk1.8.0_92/bin/java -jar ~/bitsquare/gui/target/shaded.jar

The previous examples won’t work. Arm distributions of JDK8 no longer include JavaFX which is needed to compile the packages. That’s why none of the out-of-the-box solutions are working.

This includes all the steps. I got it working on a Raspberry Pi 2. The script itself may need a little tweaking to pass in a single run, but I just wanted to put this up before another person got ahead of me.

:slight_smile: by about 30 seconds I think

I think you left the btc address from metabit on your script. jsyk

Yeah, he did most of the work… I just enjoyed the challenge of debugging it :slight_smile:

I’ve boosted the priority for java 8 in the script now so no need to run the java 8 executable direct.

Final nail in the coffin pushed!

The reason you’re getting the error is because the RPi was not devoting enough memory to the GPU.

Go to raspi-config and share the memory 50/50 and it runs

EDIT: Might have spoken too soon. It’s starting up and everything seems to be running. But it’s not connecting properly. Sorry for the false hopes. The GPU memory was just one more step.

1 Like

Gotta love a bit of collaboration!

So good collaboration, and me, i make nothing xD

Why can’t just download and run the .deb file?

He wants to test new fonction in her Raspberry Pi