Another stuck on launch screen issue

Using Tor mode in the Bisq app. Launched Bisq, stuck at connecting to Bitcoin network. Bitcoin network peers: 1, then 2, then 1. Bisq network peers: 7. Been stuck for about two hours so far. I am attempting to resync the SPV file. On a previous attempt, it took about four hours to complete 1%. Is this a Bisq issue or Tor, or other? I’d like to clear the Tor instance but can’t log in to do it. Tried restarting the app a few times.

Maybe related: I also use a VPN, and switched from double hop to single hop, no difference.

Thanks for any suggestions.

Edit: I have four open trades as a Maker/Seller. Two payments are due to arrive tomorrow but I can’t confirm received. Bitcoin network peers is now 1 and sync with Mainnet (via Tor) is at block 729372 / 1% but then Bitcoin network peers shows 0, then 1, then 2, then 0.

Here’s how to refresh tor files without GUI access

But then also consider

1 Like

Thank you. Internet speed is good (190 Mbps up, 22 down). I finally got to the login screen, entered my pw, and sync is running very slowly. It’s at block 743000 / 12% after 3 hours. I tried deleting the outdated Tor files, but same. I’ll see if the sync speeds up and completes. If not, I’ll try this suggestion. Delete all except the FOLDER hiddenservice?

if you can delete outdated tor files from the gui you don’t need to do it manually, it’s the same thing.
Your internet speed is not an issue, the giant bottleneck is tor, while installing your bitcoin node avoids all the problems of having to deal with the connection to outer nodes

1 Like

Yes, but I’m not familiar enough right now to run a node. I read that if hitting the “DELETE OUTDATED TOR FILES” button during sync doesn’t help, then the wallet being too old (over a year) might be the problem. Mine is two years old. So the next step might be to restore a wallet backup. Then the question is which one to restore from C:\Users\Admin\AppData\Roaming\Bisq\btc_mainnet\wallet\backup\backups_bisq_BTC_wallet. I assume the last one before the the sync issue appeared?

stop right there, do not restore any wallet backup or you will mess things up even more, you need to complete a successful spv resync first, whatever is the next plan of action, which in your case could be to get a new wallet Create a new wallet for your data directory - Bisq Wiki

but still, consider running your node anyway, never too soon: Installing your own Bitcoin node - Bisq Wiki

Thanks for the heads up on not doing a wallet backup or restore, and instead creating a new wallet. I let the sync run overnight and it completed. Hoping the sync issue won’t happen again on future restarts.

Are you familiar with the sync being an issue if the wallet is more than one year old? If I recall I read that in the wiki. Mine is two years old.

Yes, old wallets take longer to complete a spv resync.