App doesn't start on Windows 10

I installed Bitsquare on my Windows 10 Pro, JAVA build 1.8.0_111-b14. However, the app doesn’t start (running as administrator). No window appears and and I don’t see any Bitsquare related processes in the task manager.

I tried to start the Bitsquare- directly - the application starts but I get en error message:

Please help…


If you run from source code you need version 1.8.0_112 and follow the steps here:

Hi Manfred,
sorry but I’m just a regular (=stupid) Windows user. I tried to uninstall the app, then I installed the Oracle JDK 1.8.0_112 and reinstalled the app, I still have the same problem.

Here is my bitsquare.log file:

dec-03 09:15:42.495 [JavaFX Application Thread] INFO i.b.a.BitsquareApp: Log files under: C:\Users\XXXXXX\AppData\Roaming\Bitsquare\bitsquare
dec-03 09:15:42.498 [JavaFX Application Thread] INFO Version{VERSION=, P2P_NETWORK_VERSION=4, LOCAL_DB_VERSION=4, TRADE_PROTOCOL_VERSION=1, BTC_NETWORK_ID=0, getP2PNetworkId()=0}
dec-03 09:15:42.499 [JavaFX Application Thread] INFO i.b.c.u.Utilities: Windows 10
dec-03 09:15:42.499 [JavaFX Application Thread] INFO i.b.c.u.Utilities: os.version: 10.0
dec-03 09:15:42.499 [JavaFX Application Thread] INFO i.b.c.u.Utilities: os.arch: amd64
dec-03 09:15:42.502 [JavaFX Application Thread] INFO i.b.c.u.Utilities: 64
dec-03 09:15:42.503 [JavaFX Application Thread] INFO i.b.c.u.Utilities: JRE: 1.8.0_112-b15 (Oracle Corporation)
dec-03 09:15:42.503 [JavaFX Application Thread] INFO i.b.c.u.Utilities: JVM: 25.112-b15 (Java HotSpot™ 64-Bit Server VM)
dec-03 09:15:44.231 [JavaFX Application Thread] INFO i.b.b.p.PriceFeedService: baseUrl for PriceFeedService: http://g27szt7aw2vrtowe.onion/
dec-03 09:15:49.054 [JavaFX Application Thread] ERROR i.b.g.m.MainViewModel: initializeAllServices
dec-03 09:15:49.730 [JavaFX Application Thread] ERROR i.b.p.n.TorNetworkNode: TorNode creation failed with exception: java.lang.InterruptedException: sleep interrupted

How do I run from source code on a Windows machine? I don’t really see these instructions in the mentioned document.

Thanks a lot,

You should not need to run it from source. I just though you do or started it form terminal/console because that error should not happen when you run the binary.
On windows sometimes old installations don’t get removed properly. So I would recommend following:

  • Go to the application directory where the Bitsquare.exe is (NOT the application data directory where the wallet is inside) and backup and then delete that directory.
  • Then re-install new the app from the installer exe


Hi Manfred,
I did as you proposed, the problem still persists.


Ah I just re-read: “I tried to start the Bitsquare- directly” - so that will use your local jvm which is not adopted to support strong keys. That is expected. You need to start the exe, not the jar file yourself.

If you dont need java and u are nto a dev u can un-install java if the problem still exist. Or to apply all the steps described in the file, but that might be a bit challening if u are not a dev.

Of course I had tried to start the exe file first - but nothing happens with exe file, not even a splash screen or an error message. The log file doesn’t get updated either. After that I tried the jar file directly, with the jar file I’m getting the error on the screenshot.

Seems to be something system specific. I fear I run out of ideas what u can do beside setting up the dev environment and run form source code.

Mee too. I have some experience with eclipse. Do you have some hints on how to run from source code under eclipse?

You don’t need an IDE, its ok to build and then run the jar file. The important thing is that you follow exactly the steps in the file.

I finally got it working (built from source). Thank you.

1 Like

Ah cool! Thanks for your patience. Should work with the binary as well, but sometimes some strange system setup causes issues. Hard to find out if I cannot reproduce it…