Available balance show 0.0 after trades

I suddenly got a zero balance, though the software is running well. I bought 0.1 BTC on 13th & 14th March. Today, 15th March, I had difficulty connecting to my wallet. When I finally did, the balance showed zero instead of approximately 0.6 BTC. Can hackers identify the transacting PC so as to install password key loggers, look for seeds, etc.? That would be a weak point. I can’t also withdraw my funds in a trade to external or Bisq wallet (stuck). Should I restore the wallet? If a person responsible is reading this, please have a soft heart because I invested all the savings of a few friends in poverty-stricken Africa. It would have been better to end their lives. Please, let’s make crytocoins a moral vehicle of less greed, which is often at the cost of lives and livelihoods!!

I went to settings and it seems there are a different seed words than at account setup. Are seeds permanent or change all the time? Can administrators give me a private contact so that I can ask for help to try to salvage my wallet?

It is very unlikely that you were hacked. You Bisq client is probably just showing you the wrong balance, but don’t worry, you can always export your private keys if you can’t get it to work properly.

Seed words don’t change, so if you have different seed words, you are using a different wallet.
As long as you know your seed words, you can restore the old wallet with them.

Also keep in mind that Bisq is decentralized so there is no admin or anyone that ever had an access to your wallet other than you.

I would suggest you delete the SPV chain file in Settings first and restart the app twice. Then you can try using the emergency wallet tool by pressing cmd+e to access your funds if Bisq still isn’t showing the correct balance.

As it seems like you are using a different wallet then you previously did, you should try restoring that wallet with seed words. You can use an Electrum wallet for this if you don’t want to change your Bisq installation currently.

Just make sure you have all the seed words written somewhere in case something goes wrong and your bitcoins will always be safe.

Thanks, Alexij. It is not resolved but you give me hope. May you be blessed. I uninstalled it, reinstalled after deleting old one in AppData, but it still came up the same (with zero balance). Indeed, it could be new wallet because when I go to “Accounts, seed…”, the wallet date is today and transaction records haven’t shown any change. But my trade’s “withdraw to wallet” also disappeared without showing up in ‘operations’. I thought it was going to regenerated wallet of hacker. I will try your advice to delete SPV. Thanks.

I didn’t work. Balance stays as in image above. Giving up to try again tomorrow.

A dispute was opened by a trader (for failing to provide bank transfer message) shortly before the zero balance appeared. Is is possible that the code for the dispute replaces the wallet with a new one until dispute is resolved? But if so, it should be made transparent so that people don’t panic. 2) The seed words I saved at first set-up (version 0.6.0) have changed. I tried to use them to restore the wallet but got a warning that wallet format has also changed. We should have been notified during change to save new seed words. 3) I don’t know how to import private keys.

No.

In version 0.5 Bisq had a backward incompatible change to the network and wallet format. These two versions used a different data directory as well. The old one was called Bitsquare, now it is Bisq. They basically work as two different programs, of which the old one is dead.

You should install a version of Bitsquare prior to v0.5 (https://github.com/bisq-network/bisq-desktop/releases/tag/v0.4.9.9.3). It should automatically detect your Bitsquare data directory if you haven’t moved it, if not, just use the old seed words to recover your wallet. Then you should be able to use the emergency wallet tool (alt+e), but you might need to delete SPV chain file first in the Settings (or manually in Bitsquare data directory). If not, just remove the wallet password, restart the app, and press alt+j to recover your private keys.

As a last resort you might need to have some external Bitcoin wallet like Bitcoin Core or Electrum to import your private keys. Keep in mind that Electrum can run on a smart phone as well.

Thanks. Still not solved. I want to be absolutely sure before I do anything irreversible. I looks like it was not a good move that I deleted AppData file and reinstalled Bisq (after reading one of your forum advice, but I cant restore wallet balances on another computer without full data file). When I start it Bisq now, I get this error which I don’t understand: “keyPair must not be null. if we got the addressentry created from PB we need to have setDeterministicKey got called before any access with getKeyPair()”. I have not used cntrl + e to withdraw balances out because trade 619891 has not released his BTC.

Did you import the seed words to a new Bisq app? That error sounds like the wallet DB does not match the wallet, what is the case when you just import the seed words without the backup database.

Another reason could be some AV software, we had reports that some deleting some files (one even delete the wallet - turning the AV to a malware).

Thanks a lot, Manfred and Alexij. I have more confidence now to see it as a general usage problem and to try recovery of wallet. It is a lesson that hot storage for Hodling (not to sell) is not a smart idea. Yet it is quite scary that the database can dislodge from the display while trade history remains intact even with download and re-installation (perhaps, history is specific PC-bound but balance cannot be made that way). I did download Electrum but did not proceed because I thought that since it is a new wallet with zero balances, I will only be exporting its keys which will still give me zero in Electrum also (such a case was discussed in this forum). I don’t know the old private keys. I think I even did a backup from the settings of old wallet as well as the new one shortly before I deleted AppData so as to reinstall. But I don’t know what data exactly was backed up nor how to use it to restore wallet. The case of using seeds in a new wallet was also mentioned as not to have worked, especially if not accompanied by full AppData of old database (which I deleted to reinstall as per a certain discussion elsewhere here also; perhaps, edit that post with advice to save the AppData on USB stick before delete in case it is needed)… So, I will try both methods tomorrow (Electrum & old seed words in another wallet), once I am told that this will not mess up the previous wallet. How I will get all the old private keys to sweep them clean (without having the old wallet) is now my challenge. Well appreciated for all contributions!

Did you try installing the old version of Bisq?

No, I re-installed the latest version of Bisq. It didn’t ask to enter my password or seed words, which I was expecting in order to regenerate wallet. I then understood that it is a completely new wallet.

I started using it on 20th November 2017 with version 0.6.0, so I am not sure version 0.5- will recognize me. Will give it a try anyway on a different laptop so as to to mess the desktop installation as of now. Hopefully, I will be asked for old seed words. Thanks. P. S.Help! Downloaded .exe file and installed. I set up my old password, put in the old seed words and date below the new ones. I shut down and restarted, but the balance still came up as zero. Will an older version see the new-format btc addresses used in later trades. Any other restoration method to try?! Should I put seed words in Electrum or import private keys which I may not have again?
not%20Restored%20balance|690x248

Now that you setup old seed words, Bisq should have generated your old Bitcoin addresses from them that should hold your funds. You can remove the wallet password now, restart the app and then press cmd+j to see your private keys. You can import those in your Electrum wallet.

Hello! Before I use the private keys, I think I should close all open trades. For the last-but-one trade before the problem, the 0.1 (+0.03) BTC seems to be at my disposal in a multisig wallet, but I can’t withdraw it to external wallet (see print screen). Does anybody know what caused this? (I now know: it’s because i didn’t choose 2nd button to include mining fees leaving dust in the wallet). Should I just withdraw it to Bisq even though it may disappear?! Also, a dispute has been raised (by arbitrator?) on the trade, which says to wait for further instruction (till I restore my wallet?, chicken/egg problem).

Can you please describe what you did exactly and with which versions and which OS? Did you uninstall Bisq on Windows? If so that would explain it as it will remove the data directory with the wallet. Do you have a back up from the old wallet and/or the seed words?

The problem happened (sudden appearance of a new wallet with txn history of old wallet but wrong balances) before I deleted SPV files, restarted, didn’t succeed, then I uninstalled after deleting AppData file as per a post in the forum. Yes, I have the seeds and tried it in Bitsquare v0.4.9.9.3 on a laptop (showed zero balances), but have not yet extracted the private keys to Electrum (I want to close all open Txns first). I am re-thinking to put the seed words in Bisq wallet on the desktop to recover old wallet before exporting private keys. This is because I started out on 20th November with Vs 0.6.0 and using older install files may not give me all newer incompatible addresses. So, yes, the data directory is gone (didn’t know its importance till now else I would have saved it on usb drive). I have automatically backed up files of day before also (3/14) but I don’t know how to use them. The incident should be used to check the code again: why would a new wallet auto create itself when new addresses can be created as needed instead? Did the dispute message dislodge the database & why?

To me it sounds like the problem is caused by using v4.9.3 which doesn’t work anymore and uses different wallet format, as well as different data directory.

No I didn’t use V4.9.3 on desktop where it all happened. Only later (2 days ago) did I download it on laptop and put seed words. It gave zero balances and I have since done nothing else with it… Ok, thanks Manfred & Alexij for calming my nerves. I will forge ahead and take the risk of putting old seed words under the new wallet words so as to convert it to the old wallet, then if still zero balance, try to export the private keys into Electrum. Or is it better/easier to choose Electrum’s “I have seed words” and put the old seed words into there instead? I will be following these guide posts: https://github.com/bisq-network/bisq-desktop/issues/816 & Tutorial: How To Get The Private Keys From Your Bisq Wallet | ONION Forum Import%20seed%20words%20into%20Electrum

I am still on the learning path to understand what went wrong first (let trial & error be last resort). I suspect the wallet read from a wrong folder, so I navigated folders explorer. At 1st installation in 2017, I copied AppData’s Bisq folders into a private folder. With upgrades, I probably downloaded app into a folder under Local-settings (also under Users) which I named ‘Bisq’ (I just deleted it). If the App searches for 1st folder with that name, it may pick the wrong one. But backups were probably done in the right folders but perhaps with corrupted input, e.g. “keyPair must not be null. if we got the addressEntry created from PB (=Proto/col Buffer), we need to have setDeterministicKey called before any access with getKeyPair();” So on 15th, App didn’t find keys & created new corrupted wallet (always searching 4 keys in wrong folder according to the logs)? Tomorrow, I now want to delete corrupted files/folders, restore wallet from backup or reinstall app. Now, any tips on suspect files to delete (attached navigation below)? If that fails, restore app with seed words; failing which, I will seek to extract private keys into Electrum (keys files seem unchanged from first installation & I may get them there).

I wouldn’t advise you to delete any files until you recover your bitcoins. It is not worth the risk.
Electrum is a popular open source wallet, there is no good reason not to try and restore your bitcoins with it now, unless you have open trades or offers.