Bisq 1.4.2 seed into Electrum

I tried the following scenario:

  • Installed new version of Bisq 1.4.2, created new wallet, saved the seed, put a password
  • sent some BTC into generated address (bech32), automatically was generated another address and save it. I generated a 3rd one just in case.
  • I used Electrum 4.0.3 desktop Windows to restore/import Bisq wallet into it.
  • paste the 12 words seed, mark the BIP39 option, and leave the default settings for derivation path, native segwit
  • generated wallet do NOT contain any of those 3 addresses showed up in Bisq wallet
  • OK so then I created a new Electrum wallet, with the same seed, but this time using several derivation paths (changing the last number 0,1,2,3 etc) - result: NOT the same generated addresses.
  • I tried also in Electrum from console to increase the gap to 50. Result, the same NOT the same addresses.

Is there something else to do? I really would like to use same wallet in Bisq and Electrum.
I use it like that with the previous versions, working perfectly.

You should select Native Segwit and change the derivation path to m/44’/0’/1’ instead of leaving it to default m/84’.

For complete information about your wallet (including the above-mentioned derivation path), press Alt+j on Bisq interface.

Wow! Didn’t know about that command ALT+J in the Bisq wallet.
Worked perfect with m/44/0/1
Thank you!
Now I can link my Bisq wallet to LN :slight_smile: and buy more BTC in the same time. Cool!