Bisq 1.9.15 Fails on Whonix 17

After upgrading to Bisq 1.9.15, Bisq fails to start with this error:

Connecting to the Bisq network failed (reported error: No default Tor Instance configured).
Please check your internet connection or try to restart the application.

The error comes just as the UI shows step 1/4 of connecting to Tor.

The console output error reads:

Apr-17 07:48:20.443 [StartTor] Could not connect to
running Tor No default Tor Instance configured

Clearing Tor files and restarting does not fix. The instance had worked using Bisq 1.9.14 as recently as a few days ago. Whonix Gateway and Whonix Workstation had been configured using the instructions here:

I rebuilt both WG and WW to be sure. Same error.

Two things that might be worth mentioning:

  1. Whonix had upgraded to Whonix 17 recently: Release Upgrade Whonix 16 to Whonix 17

  2. One of the instructions (Bisq: The P2P Exchange Network), to avoid Tor over Tor, is to create a dummy file with +x as: .local/share/Bisq/btc_mainnet/tor/tor. This file seems to disappear periodically when using Bisq 1.9.15. But even after recreating it, Bisq does not start properly.

Given that error message, and the fact that the other people (ex - Bisq on TAILS - wiki needs updating - #11 by M4RKYR) who can not use Bisq 1.9.15 also seem to be using TAILS or Whonix, and given that the btc_mainnet/tor/tor file goes away, I looked in the release notes for a change to Tor but I did not see it.

Was there a change that I’m not seeing?

I can update this a little by saying that at the moment, it is working - it has started twice. I don’t know what I did differently, but I did try two things and then after failing to start about 5 times, it started (twice now).

I added chattr -i to btc_mainnet/tor/tor

I deleted the spv file manually from the command line (see Bisq wiki).

I’m not confident these are the solution. I still consider this to be a problem but if other people having the problem want to try these and report back we will start to gather ideas.

For what it can be of help, another user reported something about whonix on matrix:

It was a very specific Whonix-related issue. Bisq issued some new commands to Tor control port in latest Bisq version that weren’t present in older version. Whonix filtered those and Bisq didn’t work.

I am not able to build upon this, so do with this information what you feel is best :slight_smile:

So basically this confirms my speculation.

No problem, hopefully one of the devs will start to participate in the forum. Any dev would be able to help because the problem is finding out what changed in 1.9.15 in terms of Tor commands. The release notes don’t say, so we’re waiting for a dev to participate meaningfully in the community.

One thing you could do, if you have a way to contact this user (or a dev) is to ask them how to read the commands Bisq sends to the control port. With that information from the Bisq side of things, maybe I can fix or at least have something to report to Whonix devs.

But right now this is very much a Bisq support issue so hopefully Bisq will join the support part of the forum to share the new Tor changes with the community that are not in the release notes for some reason (or I just did not see them which could also be true.)

Thank you for commenting! A lot of people seem to be having this issue, and of course it is always better to run Bisq from Whonix or TAILS so this is an important issue.

Today this is working. I did update Whonix 17 (regular Debian updates). Maybe they changed something that will allow for whatever change Bisq made? It would be great if Bisq documented its release notes. Does anyone know if there is somewhere else I should be looking?