Bisq is not registering my SEPA account

Hi, I’ve created a new SEPA account in my wallet. However, when I want to buy bitcoin and want to select as a payment method SEPA transfer, it tells me that I don’t have an account for that.

I tried it only with SEPA transfers to different countries. Don’t know how it’d work with SEPA transfer to the same country.

And that’s all there is to it. I know that the problem description might seem quite simple, but the problem itself is quite simple.

Thank you for your help.

Maybe the simplest solution would be to rename the data directory and create a new account.

Hello @ZuLeweiner ,
did you select SEPA or instant SEPA ?

@Homard I chose “normal” SEPA payment.

I already solved the problem. I chose SEPA payment and non-euro currency. I thought Bisq would assume that I’m OK to convert my national currency to euros by sending the money.

So the solution is to set a SEPA account with euro currency.


I had a similar problem when adding a SEPA account as a second account.

Per default the form suggested the currency of my first account of type ‘National Bank Transfer’ which was not EUR.

The button for saving was disabled and there was no validation error. After changing the currency to EUR saving is possible.

Because SEPA is EUR other currency should not be given as option. That’s somehow confusing.

1 Like

Sorry for the late answer.
If you are familiar with github, you may open an issue about this point there :