Bisq not connecting to my full node and connecting to a remote node instead


I have a full node running locally. Bisq 0.6.2 shows me []:8333 as my bitcoin network peer instead of my local node.

tcpdump port 8333 captures traffic between Bisq and that host indeed and tcpdump -i lo port 8333 captures nothing.

What’s goin on?

After a couple of restarts Bisq is again connecting with my local full node.

1 Like

Maybe your node was starting up and thus not found by Bisq?

Yes, it’s possible that it was catching up with the network. Bisq log indicates that it timed out trying to connect.

It just unsettled me that Bisq connected to a foreign node instead of mine without warning. I get now that it is probably a hard coded fall back node, but I went paranoid for a second.

Maybe it could be better to warn or give an explicit choice of connecting only to a trusted node.

You can choose a custom node in the Settings. There are multiple options for connecting to Bitcoin nodes.

But if there is a local node already running, it offers no choice, and if the connection with the local node fails, it silently connects to a (hardcoded?) remote node, on clear net.

No, it just connects to the one that you setup in those settings. Local node is automatically preferred by the app, so those settings don’t influence that. At least I think so, never had my local node connection fail before, unless it wasn’t running in the first place when I started the app.

Also it uses Tor to connect to remote nodes by default. Don’t worry, privacy is very important to Bisq and it makes sure that user’s privacy is kept as much as possible.

You can check the Settings for various options you have there, including connecting to the public nodes, custom nodes or provided nodes, over Tor or not.

There was a bug in the versions before 0.6.4 which caused connection to a random public btc node if the connection to localhost failed of if the local node was syncing the blockchain (as well it led to failed broadcasts).
All that is fixed with todays release of 0.6.4.

1 Like

I am running a full node in my local network (same subnet), but not on the localhost. I configured the node in Bisq and it gets recognized and connects.
However if I want to send BTC off the bisq wallet it says “must connect to 7 nodes at minimum”

Thanks for reporting. I added a GH issues and will fix it for the upcoming release.