Bisq v0.9.0 released!


#1

Finally the long awaited new release is out!

Download either from the in-app downloader (more secure) or from https://bisq.network/downloads.

Release notes

This release is one of our biggest in Bisq’s history. Not only is the Bisq DAO code included for Testnet, but we’ve also redesigned the client from the ground up. Thanks to @pedromvpg for initiating and leading this Bisq redesign! Of course this release is packed as always with lots of bug fixes and UI improvements in general.

As we have updated to Java 10 and Oracle has dropped support for 32 bit Operating systems we cannot provide 32 bit binaries anymore.

Release notes:

Bisq DAO (on Testnet)

  • BSQ wallet (Send/Receive BSQ)
  • Governance (Make and vote on proposals, create compensation requests, change DAO parameters, issue BSQ)
  • Bonding (Create bonded roles/bonded reputation)
  • Pay asset listing fee with BSQ
  • Proof of burn with BSQ
  • Pay trading fees with BSQ

Trading

Payment methods

UI

Privacy/Security

Development

Assets

  • Add 25 new assets:
    Actinium (ACM), Bitcoin 2 (BTC2), Bitcoin Rhodium (XRC), Blur (BLUR), Chaucha (CHA), Croat (CROAT), Dragonglass (DRGL), EtherStone (ETHS), GreenBlockCoin (GBK), Kekcoin (KEK), Loki (LOKI), Mask (MASK), MoX (MOX), MobitGlobal (MBGL), MonetaryUnit (MUE), Neos (NEOS), PZDC (PZDC), QMCoin (QMCoin), Quantum Resistant Ledger (QRL), Radium (RADS), Ryo (RYO), SUB1X (SUB1X), Starwels (MAI), TurtleCoin (TRTL), Zero (ZER)
  • Remove not traded assets.

#2

#3

I’ve downloaded the new version through the prompt on the platform. Sig checked out. Installed it from the download folder after closing Bisq and now when I try to restart it, nothing happens. I’ve checked my running processes/applications and it’s not there. I’ve tried running it as an Admin still doesn’t work. Just nothing. I’m using Win 7, 64 bit. I’m trying to avoid restarting my comp, if possible. Any help would be greatly appreciated. Thanks.


#4

Try checking out the log file in the data directory.
Data directory on Win7 is at

C:\Documents and Settings\username\AppData\Roaming\Bisq


#5

The log file is there. Timestamped correctly. I’m not sure what I’m looking for in it, though. It’s quite hefty.

What I have noticed that’s a bit strange is the .exe file (in AppData\Local\Bisq) is timestamped several hours into the future. Not sure if that makes a difference but I thought it was weird.


#6

Any errors inside the bisq.log file? At the end?


#7

Nothing seems unusual. I did find this:

Dec-03 14:05:48.647 [BlockingClient network thread for redacted.onion:8333] WARN o.b.n.BlockingClient: Error trying to open/read from connection: redacted.onion:8333: Connection reset


#8

It is odd that there are no errors, other then the restart, I don’t see many options here unfortunately.


#9

OK, there are a lot of:
INFO o.b.c.PeerGroup: Download peer died. Picking a new one.

and it ends with:
Dec-03 14:05:48.681 [PeerGroup Thread] INFO o.b.c.PeerGroup: Waiting 10000 msec before next connect attempt to [redacted.onion]:8333
Dec-03 14:05:48.786 [ STOPPING] INFO o.b.c.PeerGroup: Awaiting PeerGroup shutdown …
Dec-03 14:05:48.786 [PeerGroup Thread] INFO o.b.c.PeerGroup: Stopping …
Dec-03 14:05:48.793 [PeerGroup Thread] INFO o.b.c.PeerGroup: Stopped.
Dec-03 14:05:58.881 [ STOPPING] INFO o.b.s.SPVBlockStore: Windows mmap hack: Forcing buffer cleaning

That seems as if it had trouble connecting? Maybe I’ll try another install and failing that, a restart. Thanks for your help.


#10

You can also send those logs to Manfred to take a look over a PM.


#11

Update: I’ve tried reinstalling but it didn’t work. Did a reboot and still not working. PM sent to Manfred. Thanks for your help.


#12

I dislike the new colour scheme.
Low contrast and small font make it very difficult to navigate the new format.

Bleecchh.


#13

I’m getting the same problem as megaseth


#14

It would be useful to devs to send them your log file as well.
You can strip out the private data form it if you wish.


#15

If you run into installation issues with Windows, here are some hints:

There are some known issues (not introduced in that release) with installing Bisq on Windows.
The Windows installer does not cleanup or overwrite always correctly the old installation files. If you cannot start Bisq after installation please delete the application directory [1] (not the data directory! [2]). You could also try to uninstall Bisq from the operating system but then the data directory (including your wallet and account data) will be deleted as well. If you want to use the uninstall option be sure to have made a backup first and move the backup afterwards to the data directory location.

Another issue can be Anti Virus software. We got several reports from users running into different problems. Either the AV software blocks Bisq or Tor, delete files in the data directory or app directory) or cause such a long delay at startup that Tor gets terminated and a file remains locked which can cause that Bisq cannot be started afterwards. To resolve that you need to restart Windows then the lock get released. We are working on solutions to fix those issues.

If you use Crypto currencies on your Windows system be aware that Windows is much more vulnerable to malware than Linux or OSX. Consider to use a dedicated non-Windows system when dealing with cryptocurrencies.

[1] Application directory (contains application installation files):
C:\Users<username>\AppData\Local\Bisq

[2] Data directory (contains all Bisq data including wallet):
C:\Users<username>\AppData\Roaming\Bisq


#16

Is there anything in the application directory that needs to be backed up first?

e.g. are the dispute ticket history etc. in there or are those saved in the data directory?


#17

afaik, everything personal is saved in the data directory.


#18

Yeah, as Homrad says, there is nothing in application directory that is anything specific to the user. You can safely delete it.


#19

Strange, i somehow got it running by deleting everything and installing it again.

Everything was saved, even tho i didn’t run it from my backup

Anyway, I can trade again. That’s all that counts :smiley:


#20

Thank you to everyone for your help. I deleted the application directory and reinstalled. That worked! Trading again with the new slick UI. Looks great.