Bisq v1.3.1: Take offer attempt rejected. Already taken

when trying to take an offer get error:


an error occurred at task : processOfferAvailabilityResponse
take offer attempt rejected because: of USER_IGNORED

then get a further message saying:

you cannot take that offer because that offer was already taken by another trader.
if you have already paid funds you can withdraw it in the funds/send funds screen.

Could it be that that particular trader has not upgraded to 1.3.1?

Maybe. Or someone took that same offer just moments before you tried to take it.

It only happened on one particular traders offer that I tried several times.

So it must be the client version they are using is not compatible with the new v1.3.1 client, could get round this by making a new client that forces a trader upgrade to latest client before they can create an offer.

The problem is, they might take a while to realize if they are not fussed about upgrading, I mean I could have messaged them direct but you cant message if your not already in a trade and I can’t get in a trade because of the bug. catch 22.

Tried to take another different online offer and getting the message:


you cannot take that offer because the maker is offline