Bisq won't start after installation (Win 8.1)


#1

I tried to install Bisq on my laptop with Win 8.1. It’s been installed there previously. However, when I install it now, Bisq won’t start. When I start the application, I can see it running in task mgr for a while and then it suddenly disappears. I tried to uninstall and install it, tried installing both 32bit and 64bit version. I tried to uninstall it with Total Uninstall 6 but without success.

Anyone know, what’s happening?


#2

Do you leave any funds in Bisq last time you used it on that computer?

Maybe antivirus is messing with some critical Bisq files, like wallet files or Tor files that some AVs are known to delete.


#3

No, I didn’t have anything in the wallet, so it doesn’t really matter what happens with the files. I’m using Avast which lets me use Tor browser and DeepOnion wallet just fine. And as I said, I had Bisq installed earlier.


#4

Try renaming this directory to something else and starting Bisq again.
C:\Documents and Settings\username\AppData\Roaming\Bisq


#5

I don’t have any Bisq folder in AppData\Roaming. I have one in AppData/Local, though. I tried to delete it and install Bisq again but without success.


#6

Bisq should have created a new data directory there since you deleted it, is there a log file in there?


#7

Again, I have no Roaming\Bisq folder. I can’t find any log file in the Local\Bisq folder. I tried to search for “log” via Windows Search but with no success.


#8

Alright, so what is now in that new Local\Bisq folder?


#9

A bunch of .dll files, Bisq.exe, Bisq.ico, unins000.dat, unins000.exe. There are also “app” and “runtime” folders.


#10

Yeah, that doesn’t seem like a data directory that we are looking for.

It is quite odd that Bisq didn’t create a directory in Roaming\Bisq. Perhaps it is hidden?
Maybe you will need to enable showing of hidden files and folders on your Windows installation to be able to see it, I’m not sure.


#11

I enabled showing of hidden files and also system protected files but didn’t find anything. I’m now searching the whole drive for a folder named “Bisq”.


#12

No need for that. It should be there. If it is not, it shouldn’t be anywhere else.
For some reason it seems like Bisq fails to open even before it can create a data folder with logs, not sure what we could do about it.


#13

Did you double check to see if you downloaded the right binaries?
Maybe you are running a 32 bit system and downloaded a 64 bit executable or something.
Not sure if that would cause trouble like this though, without any warning.


#14

I found an AppCrash folder. It says that it has a bad packager.dll file.


#15

Truly odd. I don’t know if it works fine for other Windows users, I use Linux myself.


#16

Yea, basically it says that the program stopped working. I (as a user) just didn’t see anything.

Thank you for your help. It’s not vital for me to run Bisq on my laptop. It works fine on my pc with Win10. I just thought that I could help you to find a bug and make the application better.


#17

I had a similar problem running a 32 bits software on a 64 bits computer.
It tried to run … and crashed silently.