Bitsquare 64-bit not starting on Debian Jessie stable

Hi all, I’ve been using Bitsquare for a bit over a year now, as my primary means to buy bitcoin, and also to use bitcoin to move my USD (where I get paid) to EUR (where I live and spend fiat). I’d upgraded to a couple days after it was released, but hadn’t done any trades.

Yesterday I listed an offer to buy bitcoin with USD, and had to turn my laptop off later. When I rebooted, I was unable to get Bitsquare to start. Instead of the usual local and request for my psswd, I simply see a blank window, shown below.

I tried backing up my data directory, deleting Bitsquare, and reinstalling, but nothing seemed to work. Any ideas on how I can move forward? Or at least on how I can recover the security deposit from my one open trade?


Oh thats very strange? Did u had any crash? Did you manually de-install (remove) the application?
Do you have the trade ID which might be disputed anywhere else, so I does not close it if you cannot respond?
Do you have another computer to try it? U can copy over the data directory there and should have all as usual.
Here are instructions to move the data dir:

If none works PM me so I give you further instructions.

Thanks for your support!

I’ll try installing Bitsquare on my netbook, to see if I can copy the application directory and keep going. I assume that should work, as I copied the application directory from my old Debian MacBook Pro to my current Debian Thinkpad X220, and it worked fine for the past few months.

However, here’s what I see in the bitsquare.log file:

Mar-13 22:51:13.487 [JavaFX Application Thread] INFO Version{VERSION=, P2P_NETWORK_VERSION=4, LOCAL_DB_VERSION=4, TRADE_PROTOCOL_VERSION=2, BTC_NETWORK_ID=0, getP2PNetworkId()=0}
Mar-13 22:51:13.487 [JavaFX Application Thread] INFO i.b.c.u.Utilities: Linux
Mar-13 22:51:13.487 [JavaFX Application Thread] INFO i.b.c.u.Utilities: os.version: 3.16.0-4-amd64
Mar-13 22:51:13.488 [JavaFX Application Thread] INFO i.b.c.u.Utilities: os.arch: amd64
Mar-13 22:51:13.488 [JavaFX Application Thread] INFO i.b.c.u.Utilities: 64
Mar-13 22:51:13.488 [JavaFX Application Thread] INFO i.b.c.u.Utilities: JRE: 1.8.0_121-b13 (Oracle Corporation)
Mar-13 22:51:13.488 [JavaFX Application Thread] INFO i.b.c.u.Utilities: JVM: 25.121-b13 (Java HotSpot™ 64-Bit Server VM)
Mar-13 22:51:14.112 [JavaFX Application Thread] WARN i.b.a.BitsquareApp: Scene not available yet, we create a new scene. The bug might be caused by an exception in a constructor or by a circular dependency in guice.

I’m not sure what that means, but perhaps there’s a problem in my Java machine? What version of Java should I be running?

no that sounds like a exception in a constructor which us used at startup auto-wiring by guice. if u can try on another machine and it is the same it is caused by some data in the local database. i fear the only thing then is that you send me the db folder (the wallet and other sensitive data i dont need). then i can debug and see where it gets thrown.

Bitsquare runs fine (though slow) on my netbook after copying over my application directory. My offer to buy bitcoin for USD was still there, too. However, Bitsquare doesn’t show the security deposit as reserved in the offer - my available balance, reserved in offers, & locked in trades all show 0.00 BTC. But when I view my offer details, it looks like my 0.03 is in the offer.

How do I force my bitsquare wallet to update from the blockchain?

What would you recommended I do on my main computer to fix bitsquare so it can start again? I’m guessing delete the data directory after uninstalling, then try a clean, new reinstallation.

did u copy over all data including the wallet?
then all should be in sync. if not it seems like a bug.
u can check the raw wallet value with the emergency tool (cmd+e). there u see the balance of the wallet. it must match the balance of available funds + reserved funds. if not let me know.

u can do a resync by deleting the spv file (described in another forum post

how to get bitsquare working on your main machine: yes try to make a clean install for all including a new data dir. backup all first.
i assume u start the binary, not run from source code, right?
which OS is the netbook?

Ah once idea: maybe it is some permission issue. have u changed user or any thing in that context?

Yes, I copied all my data to my netbook. Bitsquare seems to be working fine (I’ve accepted an offer to buy bitcoin for USD, and an offer to sell bitcoin for EUR. I though it had lost a security deposit for an offer I made on my main computer and canceled one I got it running on my netbook, but resyncing the SPV file corrected the wallet balance). My netbook is running Debian Jessie stable with LXDE, though its not very fast as its only got an Intel Atom Z530 1.6 GHz processor and 1 GB RAM.

Yes, I’m running from the binary file rather than compiling from the source. However, I do make sure to confirm that the file’s GPG signature is yours before I install it. And no, I haven’t changed permissions on anything in the Bitsquare data directory.

It may be a few days before I get a chance to reinstall Bitsquare on my main machine (also running Debian Jessie stable, but with the Gnome classic desktop).

If you find out what was the issue let us know! Thanks for your support!