Bitsquare won't start with exception "Could not create JavaWatchObserver"


has anyone encountered the problem of a not starting bitsquare on ubuntu although it was running before? I get this message in the log:
… [JavaFX Application Thread] INFO i.b.c.u.Utilities: Linux
… [JavaFX Application Thread] INFO i.b.c.u.Utilities: os.version: 4.2.0-36-generic
… [JavaFX Application Thread] INFO i.b.c.u.Utilities: os.arch: amd64
… [JavaFX Application Thread] INFO i.b.c.u.Utilities: 64
… [JavaFX Application Thread] INFO i.b.c.u.Utilities: JRE: 1.8.0_112-b15 (Oracle Corporation)
… [JavaFX Application Thread] INFO i.b.c.u.Utilities: JVM: 25.112-b15 (Java HotSpot™ 64-Bit Server VM)
… [JavaFX Application Thread] INFO i.b.b.p.PriceFeedService: baseUrl for PriceFeedService: http://h234zt7d2vztpwe.onion/
… [JavaFX Application Thread] ERROR i.b.g.m.MainViewModel: initializeAllServices
… [JavaFX Application Thread] ERROR i.b.p.n.TorNetworkNode: TorNode creation failed with exception: Could not create JavaWatchObserver

Any suggestions?


Hm, never saw that before. Does it continue complaining after restart?

Unfortunatelly it does continue to fail. After 4 minutes the GUI suggests so restart. By having another look into the log file, I saw that this exception occured before, but in between it Bitsquare was starting perfectly and I even could do some trades. System and Bitsquare restarts won’t help. I also tried to restart the network manager “service network-manager restart” but other then that I’m out of ideas.

Just a quick update on this. I finally started bitsquare via console and it worked one time, so that I was able to transfer my bitcoins. After that it went back to the previously described problem.
But I finally kind of solved the issue by running bitsquare as root, I usually don’t like to run software as root but for now I can work with that. Remember to move the appfolder to the root home directory…
Hope this helps others!

1 Like

Thanks. Should be not needed to run as root.
Maybe the control_auth_cookie file had issues?
You could try to remove all tor files inside the tor folder beside the files inside the hiddenservice folder. Do a backup before for safety.
Could it be that you started Bitsquare once as root and later as user again?

Sorry, that I didn’t respond. I just tried your suggestion on my unix system and removed all files and folders besides the hiddenservice folder. Unfortunatelly, no luck.
I startet to start bitsquare as root only after the mentioned issues. But, I am going to update to the later version, maybe the problem will resolve itself.


I have the same error too. In my case, it’s because of the inotify limitation reached (I’m using Linux Mint). Try close other programs and restart bitsquare.

Can you provide more info about inotify?

I doubt that this issue is connected to other opened programms, cause during my tests I had a freshly restarted system and just 2 terminal sessions as well as bitsquare running.

So I just updated bitsquare to the latest version on ubuntu, but unfortunatelly the problem still exists. The log shows the latest version:
Feb-28 17:57:54.510 [JavaFX Application Thread] INFO Version{VERSION=, P2P_NETWORK_VERSION=4, LOCAL_DB_VERSION=4, TRADE_PROTOCOL_VERSION=2, BTC_NETWORK_ID=0, getP2PNetworkId()=0}

…with the same error message:
Feb-28 17:58:06.738 [JavaFX Application Thread] ERROR i.b.p.n.TorNetworkNode: TorNode creation failed with exception: Could not create JavaWatchObserver

As before, running with sudo still works.

Any thoughts?
Thanks in advance and regards

This is the message and stacktrace:
User limit of inotify watches reached User limit of inotify watches reached
at sun.nio.fs.LinuxWatchService$Poller.implRegister(
at sun.nio.fs.AbstractPoller.processRequests(
at sun.nio.fs.LinuxWatchService$

This error happen when I have Visual Studio Code open. If I close the VS Code, the application run normally. Your case might different though.

Seem that the inotify limit is too small on that user. can u increase that in the OS?

I think we are talking about two different issues here.
Cause LinuxWatchService and JavaWatchObserver are not the same.
I am going to re-setup my linux anyway and I am hoping to solve this. Might take so time, but I will keep you posted.

Let us know if you find the reason and solution.