Blank trade screen and apparently btc auto-released before payment


I’ve been using Bisq for three moths without any major issue, but today after a peer took my offer the trade screen was all blank. No information about the trade state and impossible to do any action.

I tried to communicate with peer but had no response so I tried to start a support ticket with Ctrl + O. But an alert showed up instead of the support ticket. The alert said “deposit transaction is null” and recommended to resync SVP file.

I checked the trade details and noticed that taker fee tx ID, Deposit tx ID and Delayed payout tx ID had N/A value.

Then I did the SVP file resync. Apparently there were no changes, trade screen still blank. But then I checked the transaction history and saw two tx started after the resync. The first one was a multisig deposit related to this trade sending my BTC to sell + deposit and the other one was the deposit coming back to me. I checked the txs in and as far as I can see it seems my btc went to the multisig address with the taker deposit and were liberated as if the trade was successfully completed. But I never received the EUR, nor clicked the payment confirmation button. Actually, the button never displayed.

Note: The peer details say payment account age not known.

Thanks in advance for any help anyone can give.

could you please share the deposit txid for the trade, either in here on in private message here or on keybase #support channel?

The only way for a multisig trade transaction to resolve as you describe, would be for both traders to have clicked, in the correct succession (buyer first with “payment started”, then seller with “payment received”) the buttons corresponding to their end of the trade.

Of course:


I am currently studying this transaction, extended my time here for a while and I will get back to you asap

I investigated further and I think there has been some kind of error/bug but with no harm.

I just noticed the trade ID was duplicated with another trade successfully completed. So it seems I lost no BTC. The multisig deposit and payout corresponded to the completed trade.

The EUR amount and the peer of the two trades with same ID don’t match.

So, I guess someone took my offer and something failed, but the offer remained open and someone else took it, duplicating the ID, and we completed the trade.

The problematic trade still appears in my open trades tab and there seems no way to get rid of it, which is annoying, but as long as I haven’t lost any BTC, is not a major problem, and of course, there is no urgency solving it.

Thank you for being so fast answering and sorry if I alarmed someone. It seems the issue still needs to be investigated but as a minor problem. I’ll be happy to provide any useful information.

1 Like

oh, thank the hashing lords, I spent literally half a hour until now scratching my head, trying to find something wrong with that deposit tx, going over the inputs and outputs relations and the knowledge base, as it simply couldn’t have happened that the trade completed itself :smiley:
Well, information is power, and you knew something I didn’t but I prefer it this way.
The best way to address the problem would be to attach the relevant bisq.log file, there is one named just like that in the data folder, which covers the current running session, and several others that instead were saved in past sessions, so you should cross the filenames’ datetime with when it happened, and then forward that file to me on keybase #support, I then might try and find something in there, but most probably escalate it as it would be above my current expertise :slight_smile:

1 Like