Bootstrapping to p2p network failed

Cannot to connect to bisq network. I receive a “bootstrapping to p2p network failed” and this error every time I try, and have attempted to use all 3 bridge options. If possible, I would even like to find out if I can access my bitcoin wallet address so i can send my funds elsewhere. Please help a brother out, I feel like I bit off more than I can chew here.

Don’t worry you can always recover your Bitcoin with seed words or by simply exporting your private keys.

You could try deleting outdated Tor files in Settings->Network Info->Open tor settings.

Tor requires a good Internet connection, so if you don’t have stable Internet, that could also be the reason. Finally you can try using a VPN to see if your IP might be blacklisted by the Tor network.

Thank you for the speedy reply. How can I export my private keys?

ctrl-j to dump all the keys (or alt-j or option-j depending on your OS).
There is also emergency wallet tool: cmd+e or ctrl+e.

It’s saying my wallet is not initialized yet and my emergency wallet fund is 0 even though I sent a decent amount of coin to the address on the program. Maybe my internet is not optimal for using this program? (in singapore currently)

Try deleting your SPV chain file in Settings.

If you have your seed words, there is nothing to worry about,

I cannot open the program whatsoever and didn’t write my addresses down anywhere so I don’t believe I have access to my seed words

If I understand well, Bisq was working well before ? which version was the last version which worked ?
Which Bisq version are you trying to use now ?
Is it on the same machine ? Did something change on this machine since (eg internet parameters) ?
What type of internet connection do you use ? (eg wifi/wifi)
What is your OS ?

If you have changed location with your computer, it may be that the FAI you use now is blocking connection to tor (?).
Do you try to use Tor with another appli, eg with torbrowser ? Does it work ?

It is a bad idea to deposit funds into a bitcoin wallet without making a backup or having seed words.

One thing that crosses my mind is checking rolling backups and if you can restore from them.

Installed it and tranferred funds to it May 6th, I believe it’s likely that it’s still v1.1.2. I am using the exact same machine, have not updated to the program (to my knowledge) and have used wifi in both instances, except I put funds into my wallet in America and I’m in Singapore now.

I don’t believe the file location has changed and my OS is windows. I have recently downloaded TOR and it appears to work for normal web sites, I have not tried .onion addresses.

Did you try clicking on that “Open Tor settings” button in your screenshot and then “Delete outdated Tor files and shut down” and restart Bisq?

If that doesn’t fix the issue and you are able to access .onion addresses with Tor Browser (you could try https://3g2upl4pq6kufc4m.onion/, which is the DuckDuckGo search engine’s onion address), you should definitely report this issue on the GitHub issue tracker.

I found this an issue which seems very similar to yours (same “Unsupported private_key algorithm. Did Tor get a new key type for hidden services?” error message):

Thanks I appreciate it!