BTC lost? Never recieved it after trade

Hi, I’ve been making a few BTC buys lately. The most recent one has resulted in me not having the BTC I bought in my possession, somehow.

After sending the fiat, it proceeded to the end of the trade where I can withdraw or keep BTC in the bisq wallet. While on this page, that BTC was NOT SEEN IN MY ACTIVE BALANCE, which is confusing.

I chose to withdraw, and received the notification: “warning: the fees for that transaction exceeds the available funds or the value is below the dust amount.” I tried a couple times to withdraw out, but same error showed. I finally tried keep in bisq wallet, got the congratulations completed trade message, and had not btc in my bisq wallet. What happened? I don’t think any error was made on my end. Is there anyone who can look at the trade record or access this information? Thank you.

in the first case when you tried to withdraw to an external wallet is likely you did not have enough funds to make the transaction so this seems ok.
The second case is weird though as you should see the funds.
Maybe recheck again, make a backup and try a SPV resync (Resyncing SPV file - Bisq Wiki. ).
If this still not works, then my suggestion is to go to Keybase and share with @jmacxx your logs (Data directory - Bisq Wiki) so maybe he can help you.