Cannot get pass Tor Auth


#1

I cannot get past the TOR connection when launching Bisq, why? It keeps saying Tor cannot authorize cookie


#2

Is Bisq saying that ? or the OS ?
Can you post a screen copy of the message here.

What is your OS also and your Bisq version ?


#3

I am not near my PC as of now. But I have Bisq 0.8.0 and my OS is windows 8.1. When I pull the logs for Bisq, it looks like the issue is on the Tor side.


#4

Do you by chance have Tor already installed and running ?
(if it is the case, that causes often problem -> “Tor over Tor”).


#5

Yes I have tried running tor first then Bisq and I have also tried running bisq alone. Should tor be completely uninstalled?


#6

I don’t think Tor needs to be uninstalled.
But you should not have Tor running independently, and try to run Bisq after that.
This will cause a “Tor over Tor” issue (which is not specific to Bisq).
Bisq has it’s own Tor implementation and is self sufficient from this point.
So, be absolutely sure to not have Tor running, then run Bisq, and it should work.


#7

Yeah, I guess that is a good idea to try, but I have doubts that will work out. Tor over Tor issue is mostly on TailsOS that routes all traffic over Tor, otherwise Bisq uses it’s own tor and doesn’t mess with other programs running over different tor instances.

You can send @ManfredKarrer a PM with your log file, it could help out to determine a cause of the issue.


#8

I have tried that as well but no luck. Here is my error.

[NetworkNode-9999] INFO i.b.n.p.n.TorNetworkNode: Starting tor
[NetworkNode-9999] ERROR i.b.n.p.n.TorNetworkNode: Tor node creation failed: java.io.IOException: java.io.IOException: Auth cookie not created
[NetworkNode-9999] INFO i.b.n.p.n.TorNetworkNode: Restarting Tor
[NetworkNode-9999] WARN i.b.n.p.n.TorNetworkNode: We stop tor as starting tor with the default bridges failed. We request user to add custom bridges


#9

On Windows sometimes a tor file get locked and only after a Windows restart the lock is released. o if you are on windows, please restart, then backup the data directory and then delete the tor directory inside the data directory. But do NOT delete the hiddenservice folder, that contains your private key for the onion address. After that start Bisq and hopefully all works again.