Can't connect to Bitcoin Network

I changed the setting to connect to my own Bitcoin full node, on an internal NAT’d address. However, I think TOR is still enabled; I don’t this combination will work. Now, when I start Bisq, it’s stuck at “Connecting to Bitcoin network” and I can’t access the settings to disable TOR.
Is there a config file somewhere that I can edit, or some other way to edit the settings?

I used the --help command line argument, and learned about the --useTorForBtc= and --btcNodes= arguments, and used them to disable TOR and connect to some public nodes I found listed at Bisq is currently syncing with the Bitcoin network, almost 50% done. Hopefully I’ll be able to get in and put the settings back to their defaults when it’s done.

Final Update: Once the sync was complete, I was able to go to settings, and put the Bitcoin and Tor settings back to default, and restart normally with no problems.

1 Like