Can't connect to Tor after 1.9.9 update

Downloaded the new version twice now and tried connecting through different bridges as well. Nothing works and brings me past (1/4) Connecting to Tor.
Any help is greatly appreciated.

Could be a corrupted wallet or a problem connecting to Tor.

I would first try connecting using another internet connection if one is available.

Do you get any error messages?

Can’t try another internet connection sadly.

In terms of errors, nothing pops up.

The software is continuously trying to establish a connection. The only thing that happens is that after a couple minutes the option to change the Tor network settings appears while still trying to connect.

There is nothing that changed with tor in the last version that I know of, I have had this problem in another situation, and when it happens I just forget about Bisq for a while and leave it running no matter what, a few times I refresh tor files, it will connect sooner or later

I let it running for 20 hours today and it doesn’t help haha
Tried on my macbook now but there I can’t even install the programm.
I seriously don’t know what to do except for changing to another service at this point.

If it does not work in 5-10 minutes, better try again.
Have you tried renaming the hiddenservice folder at /home/user/.local/share/Bisq/btc_mainnet/tor/hiddenservice/? If you’re not using linux, directory will be different: Data directory - Bisq Wiki

I just came here to say I think that since 1.9.8, there is a problem with Bisq on whonix. It was working fine on 1.9.1 if you use the settings explained (poorly) online. But now the tor address is not reachable. Maybe whatever they changed with Tor is affecting your situation and mine.