"Confirm payment receipt" not working

Hi,
I sold a few crypto coins and the buyer sent me fiat, everything’s fine, the trade reached the “Confirm payment received” step… Now I want to send him the coins and get the “Completed” status, but when I click on the “Confirm payment receipt” button I’m just getting either a stuck spinning wheel with the “Sending confirmation…” message, or the “Please send confirmation again” (which I do with the same results).

I’m using v0.5.3 by the way, on macOS. I tried rebooting the Bisq app several times, with no luck.

Also: the amount in “Reserved in offers” or “Locked in trades” is 0. Does it mean that the coins were actually sent?

What can I do for my trade to reach the “Completed” status?

EDIT: Just seen in the “Transactions” tab that I got a “MultiSig payout”, seems that I got my seller deposit back with my first click on the button “Confirm payment receipt”. However my trade is still not labelled “Completed”.

It seem that it is just not displaying it properly. The trade is practically over. The other trader might even see everything as competed. Since you got your deposit back, you are good to continue. You could always withdraw your funds from the client to an external wallet, make a backup just in case of your Bisq data, and reinstall the client.

Thanks. However, how can I be sure that the buyer really got his coins?

Well deposits are locked in a multisig, so I assume that you and the other trader got your deposits back in the same transaction. After all, he had to sign it, since arbitrator didn’t get involved (no dispute open).

If I open a dispute, the arbitrator will be able to see if the buyer got his coins, I suppose? Would it be a good idea?

Not sure if this i understand fully… On the completed screen can you see 2 buttons at the bottom? Something like move funds to bisq internal wallet or external wallet? when you press the bisq wallet button the trade should “close”/complete.

Yes, but if the buyer didn’t get the funds, he would have opened the dispute after the trade duration is over. You probably shouldn’t worry so much, everything is probably fine and if you got your money back, then you couldn’t have done anything wrong on your part. You can open it if you want, since there was a bug and you can’t be sure. But since you got the deposit, there is no point for you to open it really, the other trader should complain, but his wallet already signed the transaction to release your funds or the arbitrator did, there is no other way, so you shouldn’t really worry.

I think he might have not even come to that. He seems to be stuck during the trade process and can’t progress with his GUI from “Confirm payment” step, but the purpose of it should be fulfilled. I am not sure if the max trade duration elapsed tho.

The trade duration is not over, there is 2 and a half days remaining, I even got an alert message about that a couple of minutes ago (and the remaining time now shows in red).
I still get the “Confirm payment receipt” button on the “Open trades” tab, along with the message “Please send confirmation again” (is there a more detailed error log somewhere?). I click the button from time to time, only to get the spinning wheel (“Sending confirmation…”) stuck for a while.

As I said, I got my small seller deposit back, and I even transfered it to my external wallet. All my Bisq balances are now 0.

What I don’t get is how the buyer signed the funds/deposit transaction (as they have been released). The only explanation, as you say, must be that my fiat payment confirmation has actually be sent before, and all this is a pure GUI glitch. However it is an embarrassing one, as it throws doubt on the transaction for honest sellers (and buyers) that could not fully understand the nature of the bug.

I’m going to open a dispute just to really check if the funds were sent to the buyer.

By the way, I have spotted what the buyer’s real name is (from bank transfer information) and I have a way to get in touch with him on the Net. What is Bisq official stance on this kind of external communication?

It is generally not provided as an option for scam reasons, but sometimes there is an email field in order to get in touch with the other trader. It is a decentralized exchange and since you have your deposit back, no one can really tell you what to do :slight_smile: Contact him if you think it is for the best.

Hello daf,

My Bisq ‘Login Screen’ did not highlight the Login button. The only button was Forgot Password.

I have my password but the Login button still does not highlight after rebooting my computer.

I have not received the SF coin and I cannot access my funds.

I did not think there was support for Bisq. I did not know how to create a post like this.

Is there anyway I can push this through and we can complete the transaction.

Thank You!

The wallet addresses are still valid for both sides.

Can we get an arbiter to initiate the final moves and verify payments, please.

Thank You!

It sounds to me like you are not trading with @daf .
He seems to be selling his BTC/LTC for fiat and you seem to be selling your BTC/LTC for Siafunds I assume. You are both sellers in your own trades.

It would be better if you post your bug in a new topic in the #support category.

@Ultra

Have you managed to login again? You need to enter the password before the button gets activated.
I am one of the 2 arbitrators and if the trade period expires without the trade being completed you get displayed a button for opening a dispute. Then the arbitrator checks the case and does the payout to the peer who deserves it.
If there are technical issues you can open a dispute also earlier with cmd+o when the trade is selected. But don’t do that without reason. The arbitrator is not a customer care agent for answering questions. It should be only used if the peers cannot complete the trade.

If you are not sure how to use Bisq please check out the videos and the tutorials like those:


EDIT: After reading your other post I understand now what you meant with seed data… See my reply on the other thread