Corrupted my AppData folder by mistake - how to re-establish my install/account?


#1

I was tweaking some options and for some reason I right clicked in my main user account folder and under properties I selected the “hidden” checkbox by the “attributes” section. I realised my error and cancelled the process, but it had already worked a fair bit. I then did the opposite, and unchecked the hidden tab.

Now I can’t launch Bisq (I’m currently on a different install so I don’t have the error message to hand, but will update with it asap), or Firefox, or Opera - Firefox reports “Your Firefox profile cannot be loaded. It may be missing or inaccessible”. I haven’t tried much else than that so far.

I’m in the middle of resolving a dispute for a sale I made from that account (the buyer forgot the transaction ID in the transfer), and I think we should be at the end of things there as the last thing I said to the arbitrator was “I assume we are going ahead, I have recieved X, Y information and I’m happy”. But I don’t know if the arbitrator or the buyer will want to talk more. Hopefully the arbitrator will unlock the btc now and this won’t matter… it’s been going on for a few days due to weekend and myself going away for 36 hours.

I did export my account prior to this and also have imported my wallet and account into a new install on another system. I made the mistake of assuming my account will have the transaction history included. I’m at the stage of just toying with the software and getting to know it.

I probably have below average technical knowledge as far as bitcoiners go. Any assistance will be helpful, I am competent at following steps.

So, I’ll be searching how to reinstate my corrupted appdata, but preliminary searches don’t look good, so a reinstall may be on the cards.

Is there anything I can do for my account with it’s transaction and message history? I copied all the bisq folder files from the install locations, and was going to try inserting them into my new install on the other system, but it was at that time I realised that a lot of stuff had been corrupted and bisq wouldn’t lauch any more.

Hoping that it’s just one file that needs adjusting/reverting.


#2

I am not sure what happened here. As I understood you just made some files hidden, but I don’t know why that would affect app from working correctly.

It has been a while since I used Windows, but I would assume that hiding files and folders only affect the file explorer to not show it (unless you enable showing hidden files in the control panel or whatever it is nowadays).

Either way, it might be the best to contact the arbitrator on the forum here and let them know of the issue. If you remember your trade ID (or can read if from your bank account as a reason for payment) we can figure out who is the arbitrator for your trade.

Currently there are only two arbitrators , @cbeams and @keo, so this is one of their trades.


#3

OK thanks, yeah I think it’s more to do with attributes FOR hidden files and folders, so some of their attributes were changed. Generally hidden files are pretty important in windows, and this was the whole User profile folder I messed with, so lots of apps in there and other stuff.

I’ll get in touch with the arbitrators.

Is there a way I can move a whole account plus history from one install to another? Or is it just the account settings/label I export, and not my message and transaction history? Was I on the right track to copy all of the installed files (as long as I can uncorrupt them)


#4

Yeah, you were on the right track. Data directory is all you need and the two installations will be identical. Creating backups from the app is pretty much the same thing as far as I can tell, so if you have made a backup you can try restoring it with that.

Otherwise there is nothing to worry about. Worst case scenario if you have your wallet seed you can always restore access to your private keys. Your BTC are safe, it is just good to let arbitrators know, just to make process faster.


#5

I restored the account backup and wallet, and neither brought my transaction and message history. No matter, as long as I can talk to the arbitrators, I won’t really need the history and message log, although it’s nice to have…


#6

EDIT: tried alt-e and I can see both deposits, haven’t tried to send them. The “available balance” at the top right of bisq app shows 0.00. Can I not see the balance because it is less than 0.00?

OK so it looks like the transaction was completed last night for me. I don’t have Support history or Portfolio history but I do have my wallet working so it shows me all the transactions under the Funds tab. I haven’t heard from the arbitrators but that’s OK.

A new issue is that I can’t see my deposit refunds in my wallet, even though I have completed 2 transactions now and I have 2 X “received funds” in my wallet transactions for 2 X deposits.


#7

It seems like arbitrators completed the dispute then :slight_smile:
You can go ahead and withdraw those funds now and rename that data directory so the app creates a new one on the next start. If you want to keep the account age you can follow these instructions

I’m not sure about the balance thing, maybe it doesn’t show anything smaller than 2 decimal places.


#8

I assume you are on Windows. Not sure which folder you have set to hidden but might be the application directory partent folder if Firefox also got problems. Try to search for Windows support to resolve that. I am not a Windoze user…
You can copy the Bisq application directory over to another computer then you have all the same. Make Backup as well.
The application directory is at:
Windows 7,8: C:\Documents and Settings\username\AppData\Roaming\Bisq
Windows XP: C:\Documents and Settings\username\Application Data\Bisq


#9

Yes windows, after all this, actually all I did was change my folders to “read only”…

Cheers


#10

Hum, be careful with that, because Bisq for instance writes permanently what it does in logfiles, as long with some other informations in other files.
If putting the concerned folders in “read only” mode prevents Bisq to write its files, this may cause problem.