Deposit transaction ID - Transaction not found

Trade is stuck on Step 1 “Wait for blockchain confirmation” for 3-1/2 hrs now. The Deposit transaction ID shown is not found by block explorer(s).

Version: Bisq-64bit-1.1.6.deb
Trade ID: efeikv2-bfc01e8c-6541-49ed-8c7d-ff1f17c21877-115
Deposit transaction ID: 4e96b45716582fc18b2ab8aabceaaa5c450412329644858625ed4966dcf84ab6

Tried:

  1. shutdown/restart Bisq. No effect.
  2. chat with counterparty - not online

edit: I found log entries for the trade.

Sep-21 16:19:16.358 [JavaFX Application Thread] INFO  b.c.n.a.TradeEvents: We got a new trade. id=efeikv2-bfc01e8c-6541-49ed-8c7d-ff1f17c21877-115
Sep-21 16:19:16.541 [JavaFX Application Thread] INFO  b.d.m.s.p.PreferencesView: tx fee = 0.0000005 BTC
Sep-21 16:19:17.069 [JavaFX Application Thread] INFO  b.c.p.f.FeeService: BTC tx fee: txFeePerByte=10

The transaction could have been replaced with RBF. Can you check the maker fee txID?

Thanks goraelec - the maker fee txid is

c10e3ecf7a516b687afefcbf86d00c26497f84dcc7640d7a7d5d998a5d40d179

and is not found by block explorer.

The taker txid is

4df815d6a4b6250d965a40dfa7118e023b74e0f1dc1663401932c05ae2f5665e

and has many confirmations already.

Thanks for any advice!

@bit-stacker, the taker is you, so it’s okay for your transaction to have many confirmations.

Can you guys (@huey or @christoph) have a look? I’m not sure how to troubleshoot this

@bit-stacker @goraelec
There’s an issue that has bee causing an error when broadcasting transactions. In this case, it seems that the make offer transaction wasn’t successfully broadcast but the Bisq Network still accepted it as a valid offer.

@bit-stacker
Please open an issue on github.com/bisq-network/bisq/issues, and open a dispute on the Open Trades screen in the Bisq app by pressing ctrl+o.

Thanks @huey and @goraelec for your help.

github issue: https://github.com/bisq-network/bisq/issues/3305

I also opened a dispute in the app. Please let me know if there is further information or assistance I can provide.

Thanks support for quick response and resolution of this trade.

Sure. Good luck with your other and upcoming trades.

Hi @goraelec and @huey

Something still broken - transactions are not making it to the blockchain.

I see the dispute payout transaction from earlier is still not found on blockchain:
https://www.blockchain.com/btc/tx/8391d4799bffdd9d80349e5d4324eac5b45fa77179ac340bcd8cdb36f2f34cfc

Without realizing, I tried to send bitcoin from my Bisq wallet and it failed to appear in the mempool in time.

https://www.blockchain.com/btc/tx/2642b5e520bd407d2385bf6a60f8d7492a0ad76d5333959a73ba215bde390b8a

My log entries include:
fee 0.0000815 BTC for 813 bytes (10 Satoshi/Byte)
which looks reasonable (about $0.81 USD)

I see the onion stuff and peer messaging going on. There is an entry:

Sep-22 14:02:25.383 [JavaFX Application Thread] INFO o.b.c.TransactionBroadcast: broadcastTransaction: We have 9 peers, adding 2642b5e520bd407d2385bf6a60f8d7492a0ad76d5333959a73ba215bde390b8a to the memory pool

but the transaction is still not there.

I am on latest 1.1.6 - could this be a problem? Would it help if I upload the log file?

Thanks!

@bit-stacker, yes I’d suggest sharing the bisq.log file on the Github issue you’ve created.
Meanwhile, if you’re connecting to your local host or a custom node it may be worth trying the default and connection to the default BTC nodes. Also, try to turn off your VPN if you have one on, it may be causing issues.

I updated the issue 3305 with the log section. Hopefully it can shed some light. I was using the default and not running my own node. No VPN involved. Thanks again.

Hi @huey - would you recommend I delete all Bisq files, reinstall and recreate my wallet from seed words and date? Would that make Bisq forget about the unbroadcast transaction?

Did the “Delete SPV and Resynced”. Wallet looks ok. Did a small send to an outside wallet and it was processed immediately.

Thanks all!