Duplicate transaction


#1

Had an error with trade ID 950910 (Arbitrator involved) had to restart my system, new error shows up as above.
Fiat funds have been received.


#2

Did you restart just once or did you restart several times ?


#3

restarted my system only once.
Attempted to restart Bisq numerous times. Running Ubuntu 18.10


#4

you can refer to this thread:


It was a similar issue, an it was solved successfully.

Read carefully Manfred’s answer from May 12. And the rest.
Make (of course) a backup before doing anything.
(I’ll add to also export all useful informations)
… I hope you have already some backups.


#5

Yes I have backups, but not for this trade.
Will the arbitrator and the buyer be able to close out the trade if I am not online?


#6

Can you verify from you side, eg with https://www.blockchain.com, if your bitcoins have been delivered or not ?
I assume you are the maker in this trade ? is it the case ?

PS : when using a block explorer (or any crypto operation), better do it with torbrowser.


#7

Where can I find the Transaction ID outside of Bisq?


#8

Normally you should be able to see your Bisq wallet address (for this trade).
Then, with a block explorer, you should be able to know if the bitcoins you putted at this address for the trade are still there or not.
If the bitcoins left this address, then it’s presumable they reached your buyer’s address.


#9

Bisq won’t load so I cannot see the address for this trade. I know the funds are locked in Trade. Would be good to talk with Arbitrator.


#10

Did you notice the onion address of the arbitrator for this trade ?


#11

No I didn’t record it. Just the Trade ID 950910


#12

We have a slack channel devoted to arbitration. I signaled your case there.
(You can of course also join this channel if you want).


#13

Thanks will follow up there too.


#14

Trade ID is enough, arbitrators will find your case and solve the problem for that trade so you don’t have to worry about it.

As for the error itself. just try to restore from one of the wallet backups from btc_mainnet/wallet/bisq_BTC_wallet/backup. Just replace btc_mainnet/wallet/bisq_BTC.wallet with one of those files.

For example choosing a wallet file that was created right before the bug or 1 or 2 before that, should remove the double transaction from your wallet.

EDIT: Changed the title for future reference.


#15

Have u tried deleting the spvchain file? if u cannot start bisq u can do it manually. go to application folder and there inside the wallet sub folder there is the spvchain file. first backup the whole data dir folder then delete the file, then start bisq. it will resync and that can take some time and cpu. once its done restart again. then the issue should re resolved. if not u can try the oldest wallet in yoru wallet backup dir and use that and resync again the spv chain.


#16

I’ve deleted the spvchain, the software still comes up with 0 Bitcoin network peers and the same duplication error.

I’ve even gone to the extent of uninstalling and reinstalling - same error.
There was about AUD$200 left in wallet.


#17

Your coins are safe as long as you have your seed words.
With arbitrator’s help, your last trade should be fine as well and your security deposit safe.

Have you tried restoring from backups as mentioned above?
That is the only way that we know it helped in the past.


#18

Ok, then take the oldest wallet backup file and rename that to use as the wallet. delete again the spv file. make backup before…