Error starting Bisq java.lang.IllegalStateException. Solved

Hello, I’m using Win 10, I was using Bisq normally, I have an offer in course, shut down computer and when I restart I find this:


I tried removing Tor archives, as Bisq suggested, but anyway it looks that the problem has nothing to do with Tor.

Hello, so restarting doesn’t solve this issue ?

No. And I moved directory data to Linux, where an old (last week) version of data directory worked fine, (funds safe but the offer was not accepted yet) and when I moved the same directory data to Linux is displaying the same error.

By datadir I mean the /.local/share/Bisq folder, and its equivalent in Windows.

Do you have a PendingTrades file in your data directory ?
Did you delete such a file ?
Anyway, with this kind of question with such error message, I suggest opening an issue in the github. You may have more chance to get an answer there (more frequented by devs).

I have only copy pasted old and current files at a different operative system, so data is not lost but yeah I have pending trades, I’m waiting to receive fiat payment.
I’m going to report this at github thanks.

But do you have a PendingTrades file in the data directory ?
If not, this may be the cause of the issue.

There’s a “Pending trades” file under Bisq\btc_mainnet\db. I can’t read it in plain text.

I already opened the issue on github, I guess it’s better to continue there.

Edit: Issue solved deleting wallet/bisq.spvchain file and starting Bisq.

1 Like