Forgot my password and tried to restore wallet


#1

Hello,

I read another topic about this, but didn’t really understand from that what I’m supposed to do…

So I have a bisq wallet which I forgot the password to. I clicked the “forgot my password” button and filled in my seed words, though it didn’t let me fill in all of them. I have 12 seed words and the “restore wallet” only lit up when I had entered 9, why is this? So, I clicked the “restore wallet” button with only 9 words entered. Then I got a warning saying that my wallet is not empty, and that I should withdraw my bitcoins first, I ignored this warning because I understood from the other topic that I read that it should be safe (as I’m not restoring with a different wallet). Then I got an error, which I unfortunately don’t know the error code of because it dissapeared when I clicked on the report error button. Now when I open Bisq it is not encrypted with a password anymore and my balance is at 0.00. So I guess it did restore in spite of the error… However, now I don’t really understand what I’m supposed to do to get my bitcoins back and would really appreciate some help on the matter.

Thank you
Olle


#2

Hello Troptop,
You may try Settings/Network Info/Resync SPV chain.
(warning : this can take time and CPU if your wallet is old).
This should bring you back the correct balance.


#3

As a last resort, you could also rename your data directory and restore from seed words then.


#4

Thank you for your response, however I tried and it didn’t work unfortunately. I tried once before I recieved the last update and one time after.


#5

I tried resyncing the the SPV chain, but it didn’t work, something else I should try before doing what you propose?

Also, what exactly should I rename? I mean the data directory is AppData>Roaming>Bisq, should I rename the “Bisq” directory?


#6

Nothing comes to mind at the moment. You can always return back to your current situation by renaming your directory back.

Yes, I mean that ‘Bisq’ directory. Just rename it to ‘Bisqold’ or something and Bisq should create a new one on next boot.


#7

So I tried this, but it didn’t work either… I don’t know, but it feels wierd that I can’t enter all of my seed words, like I described in the original post. I have just entered the 9 first words out of my 12 words, but could be another set of words I should enter… maybe this is the problem. Does anyone know why I can’t enter all 12 words?


#8

For me personally it lights up at random number of words. I think the button lights up at 3 words, but also at 12 like it should.

Not sure what is going on there. Maybe some devs know more about it. @ManfredKarrer


#9

You have to enter all your 12 words. That the button becomes active with 9 words seems like a bug.


#10

If you have not updated please do so, on Windows there was an issue with restore from seedwords with previous version.


#11

I thought so, thank you for your answer. I have updated, am running v0.9.4, is this not the latest version?


#12

I had the same problem both before and after the update.


#13

Yes, v0.9.4 is indeed Bisq’s last version.


#14

I just tested restore from seeds and all worked as expected. button gets only enabled after all 12 words are entered.
Can you just try it again. Maybe the error screwed something up. Make a backup first from your data directory, then go to account/seed words and restore. Use the wallet data when u have set up bisq the first time, if not sure use no date. Then restore and after restore if balance is not as expected go to settings/netwoek and delete the spv chain file. that will require u 2 times to start up again. just follow the instructions in the app.


#15

Allright, so, now when I tried to enter all 12 words the button did lit up, but I’m pretty sure it didn’t the first times I tried, the thing is that the button also lights up when 9 words are entered and then when I enter the 10th word it greys out again and all words become red. So, the last few times I tried to enter my seed words I might not have tried to enter all 12, because it seemed like more than 9 didn’t work. So I made a backup before (Account>BACKUP>BACKUP NOW) then I restored with my 12 seed words and the date of when I set up bisq for the first time. Then restarted, 0.00 balance, so I deleted the spv chain (Settings>NETWORK INFO>DELETE SPV FILE AND RESYNC) and restarted 2 more times, and it is still showing 0.00 balance…


#16

You might need to remove the wallet password and export your private keys with alt+j.

You can later import those into your Bitcoin wallet and withdraw your funds.

PS: You should also be able to use those seed words in some other Bitcoin wallets, so you don’t necessarily need to export your private keys.


#17

Which other wallets work with the Bisq seed words?


#18

Bisq uses bitcoinj which manages wallets under BIP44 format.
So, all software wallet able to manage BIP44 should normally do the job.

Bitcoin core is of course ok.


#19

There was an issue with the balance not displayed after restore from seed words. The funds have been there but the AdressEntryList db file which is used for calculating the balance was not updatetd properly. It only happened with wallets which have been used a bit, with a new wallet with only 1 or 2 txs it was working, that is why we did not easy spot it while testing as usually one tests with a fresh wallet and sending some coins there…
It is fixed and merged now in master:

So anywone who runs from source can enjoy the fix already, the other will get it with the next release in probably 2-3 weeks.
But you also can just use the emergency wallet tool (open with cmd+e) and withdraw yoru funds there. here u see to correct balance.