How to make Bisq open Bitcoin Core as it used to until recently?

I have used Bisq on Windows for a long time. Starting with some recent version, it has broken in a “subtle” (but very annoying) way. I can still use it, but it’s now a damn chore to send in the security deposits.

The issue is that the button called “Open your external wallet for funding” has mysteriously stopped working. Previously, when clicking it, it would open up Bitcoin Core with all the data filled in to make a Bitcoin transaction.

Now, it simply opens File Explorer at “My documents”. Huh? I don’t get how that can be possible, but it apparently is.


  1. Looked all over the Bisq GUI for any “settings” or “configuration” to set the path to Bitcoin Core. No such thing exists.
  2. Looked in the “.cfg” file in the Bisq directory. It contains nothing relevant.
  3. Searched online. Found nothing.
  4. Looked in the Windows 10 settings for “default apps” and “protocols”. Bitcoin Core/Bitcoin/Bisq is not mentioned anywhere there, and there is no (obvious) way to add one.
  5. Asked this question (or a similar one) on Stack Exchange.

I would make an issue/bug report on Github if that site allowed me to register accounts, which it has consistently refused for the last few years now.

What to do about this? What causes it to happen?

Hi @SomeBisqUser thanks for raising this issue. Not sure why GitHub is not letting you create an account.

I have asked your question here regarding a current fix to external links being worked on: Errors while opening DAO proposal links on Windows · Issue #5261 · bisq-network/bisq · GitHub

Looks like this will be fixed in the next release. Thanks for raising the issue.