I can't cancel my bitsqaure open offer - emergency wallet tool not working either

I was never able to fulfill an open offer I placed in bitsquare in v0. and opening the application now it refuses to connect to seed nodes saying “no seed nodes available”. I can’t see any trades or anything and it refuses to let me close my open offer.

I can’t import my wallet into Bisq, and I’m not sure that would even transfer my open offers. How can I get my money back?

Ah yes, there were few open trades when version 0.5 got released. That was the first sort off hard fork, where the versions stopped being backward compatible from that point.

You can access your emergency wallet tool with ctrl+e and send your bitcoins to the new Bisq wallet if you wish to upgrade. The old versions are not compatible anymore and that network basically doesn’t exist anymore. The wallet formats are also not compatible so you will have to transfer the funds manually, as I said, with the emergency wallet tool if nothing else works.

So this tool allow me to cancel open trades? Is there any manual where I could read about the emergency wallet tool?

I got an error using the emergency wallet tool : (

“Error: You must have bootstrapped before adding data to the P2P network.”

What do I do now?

It looks like this error comes from here: https://github.com/bisq-network/exchange/blob/master/network/src/main/java/io/bisq/network/p2p/NetworkNotReadyException.java

And yes indeed, the network isn’t ready, which is why I can’t close my open orders normally in the first place. How can I solve this issue?

The emergency wallet tool doesn’t really deal with the offers, as far as I know, but with the actual wallet.

I am not sure about what is the best action for you to take now, all I can tell you is that you can remove the password from your wallet and export the private keys with cmd+j in case you need them to recover your funds.

I started a seed node again for the old pre-0.5 network. So you should be able now to remove your offer and withdraw the funds. Please note that you cannot import the seed words in the new app because we changed the wallet format (BIP44 now).

1 Like

@Manfed I was able to cancel my offer, thanks!

@Alex I think I’ll use cmd+j to grab my private keys, since the transaction fee bitsquare wants to do is $30…

Thanks guys!

You can set your own withdraw fee if you want in the settings. But Bitcoin mining fee’s are often a bit high on the network.

You can import the seed words to other wallets (but not latest Bisq as BIP44). I think Electrum supports the same format.

I’m having the same problem with an offer entered in v.4.9.8. The client is telling me I need to wait until it is fully connected and status is no seed nodes available. Whats the best way to proceed.

I am sorry, but v5.0.0 was the only backward incompatible release. Since then Bisq has been running on a different network and your offer basically doesn’t exist anymore.

This isn’t a bug, seed nodes simply don’t exist anymore for versions before v5.0.0
Your money is still safe however as the offer has never been taken, so you can use emergency wallet tool by pressing cmd+e to withdraw your funds from Bisq.

Thank you for the quick reply. It looks like I can invoke the emergency wallet tool but it looks like transactions are not being broadcast to the bitcoin network. I tried to send out available balance yesterday and it allowed me to send but now the transaction is just sitting there in the bitsquare tx log. When I check the Tran ID there is no record of it in the block explorer. Do I need to be connected to a seed node to send bitcoin to a new bisq address?
The status bar does show that I’m connected to 8 bitcoin network peers and synchronized with Mainnet. However, there are no seed nodes available of course as per your explanation of these .0.4 version. Please let me know if there is something else I can try.

You shouldn’t need anything other than those connections to Bitcoin nodes that you seem to be having. I suggest you try deleting the SPV chain file in the Settings and restarting the app twice.

Don’t worry, your bitcoins are safe. You can always export the private keys if you can’t get it to work in conventional way.

I will try that. Just to make sure I’m deleting the right file… is that the bitsquare.spvchain? Just curious, is there a way to cancel that stuck bitcoin transfer from the UI or I should delete the SPV file and that will take care of it?

Yes, that’s the one.

I am pretty sure that there isn’t. Deleting an SPV file and restarting the app twice should do the trick. If not you can just export your private keys by removing the wallet password, restarting the app and pressing alt+j.

Everything worked except I got an error about bootstrapping when I tried to use the emergency wallet tool like the other user.

Not sure if the alt+j to export is working on my Windows 8 machine. I do get a bunch of wallet info when I do cntl+j and I can save that to clipboard.

Where does the alt+j export to? Is there a place that would explain how I can import the private keys into my new installation I have of bisq on a different machine?

Oh, ctrl+j key might have been changed in the v5.0 to the alt+j, as it was with other key bindings in Bisq. So that is probably the same command you got there.

That info that you see should show you private keys, as far as I know. It doesn’t export it to a file, just to a screen, I think.

You can’t import private keys into Bisq however, you will have to import it into another Bitcoin wallet like Bitcoin Core or Electrum. That should be a pretty straightforward process.

I was able to import the keys into Electrum wallet. It was pretty straight forward as you said. Thanks for all your help.

1 Like