Infinite Loop Connecting to Tor (Windows 10 / 64)

I have Windows 10, 64 bit, I have tried many times to install - all in vain. I am able to connect to Tor browser but when I run Bisque app it says “Connecting to Tor”, then, at length, opens the bridge window - I have tried every single bridge and tried inputing bridges myself. Again, all in vain. I have not a need to create a bridge using Tor browser but somehow each and every time I open Bisque application it just hangs for a while, then asks for bridge info. I tried deleting AppData stuff and reinstalling more than once and once again, this was in vain. I even as last ditch tried putting on Java JDK 8 and updated my environment variables for that with JAVA_HOME thinking this may be a prerequisite but this also was in vain. At this point I can confidently assert that this application does NOT work whatsoever for Windows 10 / 64 bit. Again I have no need for bridge connecting with Tor browser so I ought not to be asked for a bridge with this application but even so no bridge works. I also ensured my windows firewall was not blocking the app. I am on my home laptop so there ought not to be any unusual firewall type issues. Please advise where a WORKING install is for Windows 10 / 64 because the one on the website categorically does NOT work - I am a developer so it is unlikely to be user error, thank you.

1 Like

I am sure that we would be having a lot more complaints if the app wasn’t working for anybody on Windows, but this issue is still of course very important to get into.
Perhaps @ManfredKarrer can look into this when he has time :slight_smile:

1 Like

Can you PM me the log files? I assume you run the binary not the jar file, right? If so you need to setup the jdk as it is shipped. We had many 1000s downloads and not complaints so I am sure it is some local issue at your environment. The tor settings show at at startup after a few minutes if tor could not establish a connection. If you have a good internet connection and no issues with Tor browser that should be rare. From my experience its about 1 in 100 times. Sometimes Tor gets bad routes and need much longer as usual. A computer restart might help as well if there are issues with too many open network files.

1 Like

Same Windows 10 problem here, my App can’t seem to connect to Tor network despite there being no problem when I use Tor browser. Any idea why this is the case?

i also have a problem on Windows 10. it worked last night and i was able to set up a trade but after my computer crashed overnight I have nothing but the same loop when trying to start bisq.

1 Like

Try to restart the computer. Might be a lock on a tor file causing that Tor cannot be started.

Still won’t connect :confused: I haven’t deposited any currency so should I try reinstalling it? I opened the log file and I got this:

Jan-01 14:46:43.520 [NetworkNode-9999] ERROR i.b.n.p.n.TorNetworkNode: Tor node creation failed: Auth cookie not created
Jan-01 14:46:43.542 [NetworkNode-9999] INFO i.b.n.p.n.TorNetworkNode: Restarting Tor
Jan-01 14:46:43.544 [NetworkNode-9999] WARN i.b.n.p.n.TorNetworkNode: We stop tor as starting tor with the default bridges failed. We request user to add custom bridges.
Jan-01 14:50:29.025 [JavaFX Application Thread] WARN i.b.g.m.MainViewModel: startupTimeout called
Jan-01 14:54:42.128 [JavaFX Application Thread] ERROR i.b.n.p.n.TorNetworkNode: A timeout occurred at shutDown

Yes if you have nothing done so far in Bisq you can delete the data directory and start over again. Seems like tor has an issue due either a locked file or maybe a AV software removed some data (got such reported in the past).

Still not working unfortunately, but I did try installing bisq on a ubuntu vm and it works fine. Do you have any other suggestion because running a vm to open bisq is a bit tedious for me :slightly_frowning_face:. I should also mention that the tor folder in my bisq data directory is empty, does this have anything to do with my problem?

As Manfred said, maybe your antivirus is deleting all the files that have something to do with Tor.
You might want to check that. What antivirus program are you using?

That sounds like AV software craziness. I even heard of a AV software deleting wallets. Some AV seems to be not much different to malware…
Btw. I highly recommend to move to Linux or OSX. Windows is just terrible insecure for crypto.

1 Like

Well the strange thing is I’m not actually using any AV software other than windows defender which I have already disabled :confused:

Yeah I’m starting to consider dual booting Windows and Ubuntu. Well thanks anyway for the help