Installation problem "error invoking method" and "failed to launch JVM"

I had bitsquare installed last week and it seemed to run, although i didnt use it to make any trades, Just opened it briefly. I had to do a system restore and i think it removed it. becasue the folder and icon were there but the program didnt work. so i did an uninstall of bitsquare and then downloaded it again. when i choose to run it and click on “install” it gets about 1/4 way through installation then gives me the following message “error invoking method” and then when i click “ok” another messages comes up “failed to launch JVM”. After that i have the option to “abort”, “retry” or “ignore”. Retry results in the same happening and i have not tried “ignore” yet. Should i try the “ignore” option? What would this do? Could anyone provide some guidance or a solution to this. Thanks in advance.

Hm… did you use the correct architecture version (32 bit or 64 bit)?
Which OS do u use?

Im on windows vista and downloaded the 32 bit version which i believe is correct.

32 bit is only used on old machines. If u use the download page on the bitsquare webpage it usually can check which version u have. otherwise do a google search how to find out which system u have. if the wrong system the installer does not work.

it is the correct version. 32 bit is what it detected. i still get the error message

Can u go to the installation directory (where the exe is inside, google where it is on windows) and backup/remove the Bitsquare folder? Be sure that you dont delete the application directory where the wallet is inside.
So after the installation dir has been removed install new. Hope that helps.
On windows there are some issues that the installer does not clean up correctly.

there is one file (Bitquare-32bit- is this the one i must back/remove? and how do i back up and remove? what is an application directory? and where is this application directory? then i reinstall? (redownload?)

has anyone else had this error message when trying to install? nothing seems to work. Would installing Linux or Lunbuntu or something help? Could you please explain the instructions more clearly. I didn’t understand them.

do you have any bitcoins in your wallet?

edit: i mean the bitsquare wallet.

I havent used it all all yet so nobitcoins. However , as i said previously i successfully installed it and opened it about a week prior and then a few days later noticed that the folder and icons were there in the menu of my computer but they had no content and nothing would open. so i uninstalled and tried to reinstall and that is when i started getting the error message. I have no idea what happened to all the contents of the folders or why the program seemed to have been partially deleted after the first installation. i still get the smae error “error invoking method. failed to launch JVM”. What does this even mean?

Hey Owen,

JVM is Java Virtual Machine and creates a Java environment to run the Bitsquare software which is written in the programming language Java. I’m not a developer, so I can’t explain in more detail.

You’re running windows vista which might not be 100% working, but let’s try once again if you wish:

Please unistall Bitsquare again and delete everything Bitsquare related you can find on your machine.

  • Uninstall as you normally would.
  • Open windows explorer and navigate to the folder containing the Bitsquare program files.These should be somewhere like: User/YourUser/AppData/Roaming/Bitsquare
  • Delete the folder
  • Please download Bitsquare again from here:
  • Make sure it’s the right version, esp. 32 vs 64 bit
  • Install and try again

Good luck :slight_smile:

ok so last time i didnt do the delete folder part so this may be the problem.
however now i have a different error message. i started the installation but it stops at about the same point as before (1/6 of the way through) here is the message:

“An error occurred while trying to rename a file in the destination directory:
MoveFile failed; code 32.
The process cannot access the file because it is being used by another process”

click Retry to try again, Ignore to skip this file (not recommended), or Abort to cancel installation.

Any ideas?

quick research suggests this might be related to your antivirus software. you could try disconnecting from the net, disable your antivir and try the setup again.