Issues Downloading Bisq for Mac: Verification & Installation Issues With Terminal Commands & Bisq Freezing

Bisq keeps on freezing when I open it up and I’m having trouble verifying the installer and signature using the command gpg --digest-algo SHA256 --verify installer.dmg.asc (the command listed in the YouTube video used to verify the signature and installer). This is located on the downloading & verifying Bisq for mac / Linux YouTube video at this link Download, Verify, and Install Bisq: Linux and macOS - YouTube.

Looking forward to hearing from the community and learning where I have gone wrong. :slight_smile:

I have also tried the commands in the recently updated version of the support article thread on GitHub (at this link Release v1.5.4 · bisq-network/bisq · GitHub). However none of the commands seem to work for verifying the installer files & signature.

I have installed homebrew & gnupg (using homebrew to install gnupg exactly as described in the YouTube video).

The Bisq-1.5.4.dmg and Bisq-1.5.4.dmg.asc files for Mac were installed before inputting these commands into terminal (as illustrated in the YouTube video for downloading & verifying Bisq on Mac / Linux).

This seems to match perfectly with what comes up at 0:47 in the YouTube video.

See here:
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 3110 100 3110 0 0 4874 0 --:–:-- --:–:-- --:–:-- 4874
gpg: key CD5DC1C529CDFD3B: “Christoph Atteneder” not changed
gpg: Total number processed: 1
gpg: unchanged: 1

Unfortunately the other commands used to verify the installer files & signature don’t work at all.
Here is my command line from the article thread I inputted into terminal:
gpg --digest-algo SHA256 --verify Bisq-1.5.4.dmg.asc

Here’s the response I get.
gpg: can’t open ‘Bisq-1.5.4.dmg.asc’: No such file or directory
gpg: verify signatures failed: No such file or directory

Here is the response I receive after inputting the command line into terminal from the YouTube video:
gpg --digest-algo SHA256 --verify installer.dmg.asc

Here’s the response:
gpg: can’t open ‘installer.dmg.asc’: No such file or directory
gpg: verify signatures failed: No such file or directory

I haven’t been able to verify the signatures or the installer files yet. However, I should mention that I was able to successfully open Bisq and get it to connect to the Bisq network & sync with the Bitcoin network (as Bisq normally should do when initially opening up), however, soon after this it freezes and I had to force quit the application.

The response I initially received when opening it for the first time was:
‘Bisq can’t be opened because Apple cannot check it for malicious software’

This happened to me the first time I ran Bisq on mac OS Catalina before I ‘right-clicked’ on the application and manually opened the application. It never played up again after that (as described in the support article), but Bisq would continue to freeze right after connecting to the network & syncing with the Bitcoin network, and the green bar would fill up (I’m referring to the solid green bar that is inside of the hollow loading bar that eventually completely fills up the whole bar horizontally from being hollow to solid green, signifying Bisq has fully loaded and is ready to go and about to open). Bisq has never opened and has always frozen after it has reached this point.

This is confusing me because I have already downloaded the files (but not opened the Bisq files and properly downloaded them into my applications folder) which is exactly what is shown you need to do in the YouTube video I’m referencing above. Unfortunately the same problem comes up when I input both commands in Terminal.

Once again, I look forward to hearing from the community and learning where I have gone terribly wrong! :slight_smile:

Import Key from Github

Open GPG Keychain application and set Christoph Atteneder’s key to Ultimate.

Validity column should turn from orange to green.

Download the installer file and PGP Signature:



Verify signature of bisq dmg install file:

gpg --digest-algo SHA256 --verify Bisq-1.5.4{.asc*,}

Output should be:
gpg: Signature made Thu 31 Dec 06:09:53 2020 EST
gpg: using RSA key CB36D7D2EBB2E35D9B75500BCD5DC1C529CDFD3B
gpg: issuer “
gpg: Good signature from “Christoph Atteneder” [ultimate]