Just used Bisq to buy, want to buy again, but having issue with deposit

Hi there, I just finished my first buy transaction on Bisq. I’ve kept all the funds on the Bisq wallet, haven’t moved it around after transaction.

However, I’m trying to buy again, but it says I have insufficient funds for a deposit.

Right now, I have <0.01 BTC in sitting in one address, and >0.01 BTC in another, but Bisq is saying that I only have the amount sitting on the <0.01 BTC address when I try to create another buy order.

Any ideas? Can I use the BTC I just bought towards a deposit?

Thanks in advance.

You should be able to, yes, if the trade is finished.
Maybe deleting an SPV chain file in Settings and restarting the app twice could help.

Thanks, I’ll try that and report back to see if it works.

I tried that, had the same error. The trade was finished 2 days ago, I’m able to transfer the funds out of Bisq, but I don’t want to move funds around to circumvent this.

Does it matter that I’m synced with my own node? I see “Bitcoin network peers:1 / synchronized with Bitcoin Mainnet (localhost)”

I don’t know why it is causing this issue :confused:

Maybe you will have to move your funds out of Bisq to fix this.

If your local bitcoin core is not synced when you start up bisq u might have issues and dont see the confirmation. just restart bisq after btc core is synced if that was the case. if the wallet still has not synced up correctly delete the spv file in settings.

I believe my node was fully synced when I tried that. I ended up moving the funds from Bisq to Bitcoin Core and funding the deposit from there for it to work, no big deal.

If it helps, I funded Bisq with 0.015 BTC, thinking I can use whatever remains as deposit for another transaction. After my transaction, I had ~0.004 BTC in one address, and 0.0725 BTC in another. Had I funded Bisq with the exact amount I needed for the deposit, I don’t think that would’ve happened, as the only address with BTC would’ve been the 0.0725BTC address. I’ll confirm on my second transaction

Confirmed that the issue doesn’t reoccur if I fund the deposit with exact amount. If there is remaining balance on deposit address that’s less than deposit required, the platform doesn’t look for other addresses with balances to fund deposit.

That’s what I think, but I’m no software dev.

How do we know if the local bitcoin core is synced or not ?
Would some additional info appear in the Settings|Network info tab ? or elsewhere ?

SPV Chain = Simplified Payment Verification Chain ?


The simplest way is to just switch to your Bitcoin Core window if you are running a GUI version and look at the bottom right if it says that it is synchronized with the network.

If you are only running a Bitcoin daemon on your machine, you can use bitcoin-cli to get blockchain info and look for the verification progress.
“bitcoin-cli getblockchaininfo | grep verificationprogress”.
Keep in mind that verification progress is usually not 1.00 , but if you see something like 0.99999 or more, you are practically synced up.

1 Like