Launch Bisq after almost three years - not working

Hello.

Please me help, I am desperate. :zipper_mouth_face:

I had Bisq installed on older computer (Windows 8.1) from December 2017. The last time when I turned on the program was be approx 19.february.2018.
In Bisq built-in wallet, I have some small money in Bitcoin currency. :sleepy:

I have made backups direct from Bisq interface from December 2017 and February 2018. The last backup have name “bisq_backup_2018-02-19-XXXXXX” (X - some number).
I remember that I typed passwords? (protection for wallet?) somewhere in Bisq… I have this passwords noticed.

Yesterday I tried to run Bisq after almost three years. :frowning:
I created a backup before running Bisq, I backuped both directory C:\users\dogwolf\appdata\local\Bisq\ and C:\users\dogwolf\appdata\roaming\Bisq\

Of course, I assumed that the three old years program would not work. :frowning:

I run the old Bisq on, program started running but remained standing and wrote: “Couldn’t make a Tor connection.”
I uninstalled old Bisq and deleted folders (I have a backups of these folders) C:\users\dogwolf\appdata\local\Bisq and C:\users\dogwolf\appdata\romaing\Bisq and install new Bisq from webpage.
I run the new Bisq, program started successfully and I closed Bisq.

From my manually backup C:\old_bisq_backup\appdata\roaming\Bisq\btc_mainnet\wallet
I copy file “bisq_BTC.wallet” to:
C:\user\dogwolf\appdata\roaming\Bisq\btc_mainnet\wallet.
I don’t remember if I deleting bisq.spvchain file.

Next… I run new Bisq, the program works, but I had “no money in my wallet”, it is possible that the program also reported an error with the some XML document…
After 1 minute I turn off Bisq and deleted bisq.spvchain and run program on again.
Later, I Delete SPV file and resync from button on the Network info tab of the Settings in Bisq interface.

After my experiments, if I tried to run the program, new Bisq will not start but it is stopped on startup screen with text: “Connecting to Bitcoin network…” with no result.

I assume that I need to uninstall new Bisq and delete both directories with data in “appdata” and install new Bisq again.

But I need to restore my old wallet from my backup (from old Bisq 2018) to new Bisq.
(As I wrote above, old Bisq of February 2018 will not start.)

Can you please help me? How restore an old wallet from backups?
I don’t want to lose my small money in BTC.

Thank you for help.

It think that the best to retrieve your BTC is to get the private keys and export them to another wallet (i.e. Electrum).
Try the key shortcut ctrl+E.

Hello. I’m a little advanced.

In past I am used Bisq 0.65.
I install new Bisq to second computer. I copy “tor” folder from new Bisq appdata\Bisq\btc_mainnet\ to old computer with Bisq 0.65. In old Bisq I deteled bisq.spvchain.

I run old Bisq. Old Bisq started and ask for enter my password…a typed password. In old Bisq I see 0 BTC in wallet. I decrypt wallet. I used ALT+J and I copy text with seed as word and private key.

But I have new problem.

I install Electrum - I chose “new wallet” - “I alerdy have a seed” - check “BIP39 seed” and wrote my seed in field. Bud next step Electrum ask for three questions:

electrum

Can you help me please.

It’s got to be legacy addresses.

1 Like

Problem solved.

I gained access to my funds.
I chose “legacy(p2pkh) addresses” and "derivation path m/44’/0’/0’ in Electrum.

Thank you “MnM” very much for help.

I hope that this “topic” helps other people with the same problem.

1 Like