Low fee withdrawal transaction only ever seen by one peer


in the past i didn’t care if one of my transactions took a bit longer to confirm, so i had my bisq transaction fees set very low (5sat/byte). i became a bit careless, didn’t use bisq for a few weeks and send btc from bisq to another wallet without checking the mempool first. now the withdrawal transaction is stuck in bisq and won’t even appear in block explorers. when i look at the transaction in the transactions tab it’s only ever seen by 1 peer.

is there anything i can do besides waiting for btc fees get lower eventually?

thanks in advance!

That transaction seems like it will not get confirmed any time soon, nor can it be accelerated. I would suggest a CPFP method, but since nodes don’t seem to have your tx, maybe a double spend is easier. Perhaps @ManfredKarrer can assist you with this.

1 Like

Just out of curiosity, why can the transaction not be accelerated @alexej996? Asking for my own learning purposes. I also have set my withdrawal transaction fee to 5 sat/byte but have yet to make a withdrawal.

What is the recommended level for this setting?

i think acceleration only works if the transaction is seen by peers. my 5 sat/byte transaction is too low to even be acknowledged as unconfirmed transaction, therefore i dont have a known transaction id which i can use to accelerate. (but thats just my uneducated guess)

1 Like

As malte said, most of the network simply rejected your transaction as it would never confirm, so you can’t accelerate it if the acceleration service can’t find it to begin with so they can’t add it to their block.

Also ViaBTC’s accelerator requires at least 10 sat/byte for the free acceleration service.

1 Like

i wanted to move all my bisq funds anyway, so i decided to just import my bisq wallet into electrum. since my initial bisq transaction wasn’t broadcasted i had no problems recreating the same transaction to the same address with higher fee from there, no double spending needed. the transaction got confirmed in electrum and now when i start bisq and look at my transaction in the transactions tab i see the confirmations in there, too, instead of the “seen by 1 peer” from before.

does this mean that in the future if i want to use bisq again i can use the same account/wallet again or is it safer to create a new one since i used my bisq private key in another wallet software? (i think manfred wrote somewhere that using the key in another wallet software can mess with some bisq db)

Yeah, it is the best for you to just create a new wallet I think.

If the fee was too low the Bitcoin nodes do not relay it. Usual values are 50-100 sat/bytes what we have seen at long running nodes. If a tx is not confirmed after a while you can resync the wallet by deleting the spv file at settings/network. That might take a bit to resync and needs 2 restarts. Then the spending tx is removed from the wallet and you can just send it again.
If that should not work you can restore the wallet from seed words or import the private key or seed words in another wallet like Electrum (any Bip 44 wallet).

1 Like

I have this same problem.
It looks to me that the fee can’t be sent any lower than 5 sats, which worked on withdrawals before and after.

This particular tx says seen by 1 peer, but isn’t in the block explorer.

I sent another tx to the same address, which worked. It appeared in block explorer even though bisq was saying it was seen by 0 peers.

Does bisq continue to rebroadcast the tx, or once some peer has seen it and possibly rejected it due to minrelaytxfee or something, bisq just gives up on that tx and considers the withdrawal done?

Deleted SPV and resynced.
Not helpful.
The tx to the same address is comfirming, but 2 other transaction in between to different addresses are stuck the same way.

5 sats is a decent fee today.
So, something is not working right.
How long should I wait before I think about filing a bug report?

I guess you can try setting custom Bitcoin nodes, if you wish, or run a local Bitcoin node that you configured to have a lower minrelaytxfee, if that is indeed the problem here.

You can open an issue on GitHub at anytime. If txs aren’t showing on a blockexplorer, there probably isn’t a good reason to wait for them to get confirmed.

It was something about my own bitcoin node.
I think it decided those 3 txs were invalid somehow, and recorded that in its database of txs to ignore.

I had to:

  • shut down my bitcoin node
  • restart bisq

The other bitcoin nodes immediately recognized those txs as valid and relayed them.
So, problem solved. Thank you.


Looks like the mempool is saved in mempool.dat
So, if this happens again, i’ll try -persistmempool set to false to restart bitcoin:

My node does have minrelaytxfee and
limitfreerelay set.

minrelaytxfee was set to old old bitcoin core level, but it was still relaying txs until this incident.

So, I wonder if penny flooding attacks are being tested against bisq nodes, for example, and limitfreerelay got involved in these txs somehow?