Mandatory Update - PIVX 3.0.4


#1

I previously PM’d this to someone, but got no reply, so I’ll make a thread for it. I just took over this function for PIVX, so if there is a preferred avenue for informing bisq on updates, let me know.

Hi there,
We have updated to the 3.0.4 wallet which has resolved the issues that came with the launch of our Zerocoin protocol update. This update is mandatory and if you do not do it, you will end up on the wrong chain. We apologize for the inconvenience, but with this update you can rest assured that you will be able to take advantage of our Zerocoin implementation.

After updating we encourage you to verify that your service is on the correct chain. This is just a precaution, but it is prudent given the rocky start around the Zerocoin launch.
So please verify your chain tip by using Presstab’s Block Explorer. http://www.presstab.pw/phpexplorer/PIVX/index.php

With this 3.0.4 update, it is safe for users to fully engage in PIVX transactions. While we will of course be updating in the future, this should be the end of this flurry of updates surrounding the launch of zPIV. We thank you for bearing with us during this turbulent couple weeks.

Please leave a reply to this post or message me at simon@pivx.org to verify that the update is complete. It greatly helps us verify that everyone is up to date and we won’t have to bother you anymore with reminders for this update.

If you require any assistance of any kind, please email me or contact our support on Slack or Discord.


#2

Hi,

Bisq only facilitates the exchange of cryptocurrencies, and currently only has an internal BTC wallet.
So Bisq does not need to do anything, PIVX traders need to manage and upgrade their own wallets as they see fit.