Missing Wallets

I’ve been trying to post to Reddit for several days thinking thats were i would get help, but was not approved. So I have been been searching for helps through out reddit and the Bisq website for help and found I can post here. About 5 days ago when I logged in to Bisq my 4 different wallets and BTC was showing. There was a new update for Bisq and so I began that install, I saw that Bisq was doing a sync process and was not finished when I needed to turn off my pc. After restarting pc and bisq the next morning I now only see 2 of my 4 wallet and i’m missing much of my BTC. Also, on the transactions screen i’m missing everything from Dec 26 2018 to now. Any thoughts? Do I need to restore from seed words or something else? I have tried deleting the old TOR files, and the SVP, and followed the instructions. However, once back on Bisq I did the Bisq update and back up last night as well in the middle of syncing…wonder if that had anything to do with it? Thanks

Bisq does not support multiple wallets so I’m not sure exactly what you are asking. Do you mean the trading accounts? There’s no issue with recreating them other than losing any signed fiat accounts you may have had. You cannot restore those from seed words, you would need to restore a backup of the bisq data directory.

As @DrFredPhD said, one bisq data directory means one BTC/BSQ wallet. You can have multiple payment accounts though. If you’re on windows do ctrl+e otherwise on Mac do cmd+e. That should show you the entire BTC balance in your wallet.

I should of said addresses not wallets. :slight_smile: So I tried that command ctrl+e which did show me what I expect my balance to be. I ran the backup as suggested and then put in a different wallet address/public key, then click the “send all funds” button. I was prompted to put in my bisq passcode to unlock and nothing happened, it went back to the ctrl+e screen with nothing being sent out. I tried this a 2nd time this time using a different wallet address with same results. When doing this command do i need to choose a public key from within my bisq wallet for this to work? Thanks for you help.

It sounds like your data directory may be corrupted. You may want to backup your current directory then try a restore from seed into a fresh directory.

is the correct dir to bakcup the local or roaming, bisq folder…or is it somewhere else?

Hey, you’ll find the correct directory for your OS here.

Note: if your are going to create a new data directory and restore your account age, signatures etc… Make sure you have no open offers, mediations etc…

I wanted to update you on the current situation. I did as suggested on the recovery site and I was able to get the balance and history to list correctly.

I do have another question. I am trying to transfer by BTC to another wallet and I get the error “The address is not correct. Please check the address format.” I have gone over this multiple times. I tried transferring some to then another wallet and received the same error again. I’m trying to transfer to another BTC wallet address so I know its not the issue of trying to use a BCH or ETH for example. Any suggestions?

Does the address start with bc1?
Bisq does not support native segwit addresses (bech32)