New install not starting up

Hi @andre! What macOS version are you running?

Mojave 10.14.6

I can enter the app now, I just type my password in the blurred window.
The problem is just the windows inside the app that don’t show when I click to see the information about an offer, for example.

If a new version is released, I may not see it because of this issue.
Will I need to remove and reinstall Bisq again?

Just noticed that the new version is up

Yes, this should fix your problem (hopefully)

The new version is working fine, thanks for the support!

1.27 update now not starting on windows.

@DrFredPhD Do you see the window or is it failing to start at all? If yes, do you use any startup arguments for your app instance?

There could be still a case where the app is not starting up at all compared to v1.2.5 if you use wrong startup arguments. Please see https://github.com/bisq-network/bisq/commit/7f9c935a8b4ace6b6fdbbbdd6e62a85b61b738ba for details.

Please have a look in C:\Users<***>\AppData\Roaming\Bisq there should be the log file located on Windows. Would be great if you could join us in the #support channel on Keybase to continue support for this issue.

Not seeing any window or process running in task manager. No startup arguments. Downgraded back to 1.25 for now.

Could you try to launch the jar file of the app manually?

java -jar .\AppData\Local\Bisq\app\desktop-1.2.7-all.jar

For this to run you need to have Java installed on your machine. I want to check if the problem is with the binary or if some configuration error prevents you from starting v1.2.7.

It should print some error when the app is not starting

After the upgrade to 1.2.7 I could not start Bisq anymore under Ubuntu 18.4.4

Starting it from the command line results in:

$ /opt/Bisq/Bisq
error: Application data directory '/home/xxx/.local/share/Bisq' could not be created

The directory already exists. Somehow the program tries to create an already existing directory…

After running from command line on windows I have the same problem with the already existing data directory

Could you please post here what is exactly printed when starting the jar file as described above. Thanks!

When you use v1.2.5 it starts up without any error?

When running with OpenJDK 13 x64

error: Application data directory ‘C:\Users\xxx\AppData\Roaming\Bisq’ could not be created.

JRE 8 32-bit seems to be not compatible as returns wrong class version error.

1.25 Still working fine

Yes, with 1.2.5 everything worked fine for me. No config file or parameter have been changed on my part.

Looking at the code of bisq.common.config.Config @245

I assume the default config file path at ~/.local/share/Bisq/bisq.properties stored in the var defaultConfigFile should be read.

However the variable defaultConfigFile is never read again and then at line 630 it tries to create the parent directory what will throw the new ConfigException(ex, "Application data directory '%s' could not be created", path);

However I didn’t compiled and debug the code. I just skimmed over it…

Does this directory exist for you already? If yes, do you have a bisq.properties file in there? If yes, could you please post the content of it here? Thanks!