No Arbitrators Listed

hi, I can see some offers listed but app says I cannot participate because no arbitrator is selected.
there are no arbitrators listed in the account section.
Can anyone help please?

I did try to update app but it does not run for me, so I am on v7.0. I have made transactions many times before so I don’t know what could be wrong. I am using my mobile hotspot for internet, no vpn, and I am connected to tor just fine, it seems.

Thanks for your time!

Why can’t you update? Also have tried to download the latest version from here

Do a backup before updating just in case.

thanks for reply.
After install it wouldn’t load or connect. I assumed it was an os issue, I am on 10.5.5 Yosemite.
Is there a reason why bisq7.0 would not still work?

I am trying the update again, to make sure.

We’re on v0.9.5 so there’s probably connections issues. I’m not sure.

i just tried again to install new app.
after d/l and dragging dmg to applications folder, i tried to open.

it asked if it is ok to open from internet file
i clicked open
app did nothing

It wouldn’t open or go further. I looked for system requirements and could not find. The download page auto identified my os, so i downloaded the latest mac version 0.9.5.

Any other ideas? thank you for your help.


I’m not familiar with MacOS, but I’d suggest you verify the file signature and then allow it to be installed.

Plenty bugs were fixed since v0.7 , payment methods removed, arbitrator addresses changed, seed nodes changed and probably many more.

It is surprising to me that v0.7 still worked until recently. I would, of course, seriously recommend running latest Bisq version.

You can look at the bisq.log file in /Users/username/Library/Application Support/Bisq to see any errors.

I also would suggest switching to a new data directory.

I think that you need to go in “System Preference” then “Security & Privacy” and you should find a section who asks to you something like “would you allow Bisq and so on…”