No update from 0.9.5 to 1.0.1?

Bisq has always prompted me to update whenever there is a newer version.
But now I’m in version 0.9.5 and it’s not giving me the option to update to the latest version (1.0.1?).
Am I the only case or is it so for everyone? What is the reason for this?

This had happened to me as well (I think for the same version numbers as you) and I was wondering what was going on. It only lasted about 2 or 3 days before I was prompted and successfully upgraded. Have you tried shutting down and re-opening the application? If so, not sure what to say. Might be time for a manual upgrade.

Thanks for the info. Yes I’ve tried shutting down bisq and restarting but didn’t solve.

On the bottom of the window where the number of the version is should be an update message.

It is/was a stupid little bug (a character badly managed in the update message).
Concerns only windows users I think.

As always, it’s recommended to update.

Do you mean updating by manually downloading the 1.0.1 version from the website? Will all my settings and data be kept from 0.9.5?

Yes and yes. Normally all settings should remain in place.
However, of course backup the whole data directory (in case of), and try to have everything closed (offers, trades, disputes).