One more stuck

Hi All,

I’m Hakan, a fairly new user in Sweden and currently having some problems.
I have been running Bitsquare on my PC and done five successful trades.
Suddenly, out of nowhere, I started to have some problems with my Bitsquare installation.
Approx. five minutes from starting the application, the orders in the order book started to disappear. One by one they left and left me with only my own buy-order.

So I installed Bitsquare on my Linux computer (Qubes OS – really good platform) with a fresh portfolio and address.
I transferred 1.35BTC to my new Linux Bitsquare wallet from my old Windows Bitsquare wallet and now, my real problems started.

Being a newbe and not fully understand the application, I just did what I have done before, clicking through the dialog´s to withdraw the coins, making the transfer.

So, it showed up in my Linux Bitsquare wallet quite fast with a “Seen by 3 peers / 0 confirmations”.
Encouraged with this swift move, I ran along and made consecutive errors that I get to in a later post (if I cannot solve it myself).

After a day, still no confirmation and I started to look in to the transaction at It now becomes clear to me that the transaction fee is only 38 Satoshis/byte, which will guarantee that it does not gets through the miners – for all the right reasons. It will be stuck.

After spending almost a full day browsing the web about my options I have the following conclusions:

  1. Wait. When the size of the mempool ( decreases, the transaction will eventually come through.

  2. Try to correct the error by some combination of tools that allow me to either undo the transaction or bump the fees to something better (currently 270 Satoshis/byte seems to be enough looking into – thoughts on this one, please.

I have now learnt, the hard way, that there is a setting for “Withdrawing transaction fee (Satoshi/byte)” Just to try, I changed it to 200 and made another withdrawal from my Windows Bitsquare wallet to my Linux one. Looking in to the transaction at, the fee ended up slightly over 884 Satoshis/byte. I have more to learn here on how this setting is working…

My current situation is not so good. I have a Bitsquare running on Windows with no order book and Bitsquare running on Linux with an unconfirmed transaction that is blocking my attempts to trade.
This is not a good position to be in.

So, any help and advice is appreciated.
Oh, thanks for a really great product and service! I enjoy it a lot! :slight_smile:

You could first try using ViaBTC tx accelerator, but you might want to use Tor Browser for privacy .

Also if the tx really uses 884 Satoshis/byte as it claims, that would mean it will be accepted in no time and if it uses 200 as you think you set, then it may take a while, but not too long I guess. Otherwise, there is probably some bug or something.

If you still get problems, see this currently pinned post

Hi and thanks for all the suggestions! :slight_smile:
When I moved funds and got the fee of 884 Satoshis/byte, it went along without any problems. That transaction was just to verify that all systems were functioning all right.

The problematic withdrawal is the first one on 1.35BTC with 38 Satoshis/byte as transaction fee. It is still stuck. Unfortunately, I initiated another buy order right after the 1.35BTC transfer and someone accepted it. Doing so, I would transfer money but the deposit is stuck the same way so I cannot mark the payment as “started” and therefor it is not possible for the person that accepted my offer to transfer any coins. I’m hoping that the deposit transaction moves along so I can start the payment process.
I might be up for my first dispute… Not looking forward at all. :cold_sweat:

I don’t think that any of this is due to a bug or a faulty database. It’s just the transactions that got stuck that now makes it all problematic.

Thanks for the tip with the tx accelerator. It will try that! :slight_smile:

Is there any way that one can re-send the initial 1.35BTC transfer order with a higher fee?
All the best/Hakan

I am not sure about the complications. I would wait for the dispute, if the problem is in the low transaction fee the arbitrator will be understanding and will assist you further. There is nothing to worry about.

Problems with slow confirmations never lead to a loss of security deposit. I am working hard to get the next release earlier out but will need still some time. Please have patience, seems the tx spamming goes on longer and more intense as in the past.