Please change browsers to use Slack

#1

I got this message: “Please change browsers to use Slack”.
Pale Moon user. Always up-to-date.
So I’m out of Slack. Permanent.

#2

Is this a general problem with your browser and Slack or is this specifically Bisq related?

PS: Found this on Slack’s website.

#3

It is only Bisq related as one Bisq communication channel less for perfect compatible non-mainstream browser because of the stupidity of Slack.
Just to let people know how incompetent Slack is.