Please Help duplicate transaction error

I’m getting the following error when I try to open bisq and not sure what to do. I have pending transactions and need to address them and can’t.

“Connection to the bitcoin network failed because of an error: org.bitcoinj.wallet.UnreadableWalletException: Wallet contained duplicate transaction”

I noticed today duplicate transactions in “Portfolio->History” tab. I have not had problems opening or closing the app. But duplicate transactions are odd.

This is probably the same issue as this one

I invited Manfred to that other topic, so hopefully he could help us out there.

Can you try to delete the SPV chain file at settings/network?

Where is settings?

top right of the bisq screen

I have the same problem. As I cannot open Bisq I deleted the bisq.spvchain file in the wallet directory, I tried to open Bisq again and I am still getting the same error message. So I am unable to open the Bisq program

Same problem.

If deleting SPV chain file doesn’t work for you either, try sending Manfred a PM of your log file, so we he can try to determine what is going on here.

Thanks. I fixed it with the info from the other thread.

1 Like