Problem trading zcash


I tried to make a zcash transaction but since I use z address transaction fails and was cancelled.

Now, several hours later cancellation, I only have 0.0002 btc while I must have 0.1990

Any idea how to fix this?

i think you’re on the wrong forum. edit: oops misunderstood. what happened to the bitsquare trade? what state is it in exactly, may need to provide more info. sounds like it may need to go into arbitration or the peer needs to be online to confirm the cancelled trade(if thats possible).

Ticket is closed. My balance is 0 and my zbalance is also 0.

Then you can see the attachment:

There is a income fund but without confirmation since about 18 hours

What other information could help?

So the funds are on returned to your wallet but still not confirmed. There is another blockchain spam attack going on (30k unconfirmed txs, normally about 4k). It should get confirmed once the attack goes back. Might take another day or so, who knows.
Our minign fee of 0.0002 BTC is usually pretty good but atm it would need the double to get into the blockchain fast.
I need to look into a solution for a dynamic fee but its not so trivial in a P2P system and requires a bigger change :-(.

Ok… I can wait one more day

I will not be able to help you here, it might also take long and we need to wait until its in the blokcchain. Worst case if it does not get in for very long we can repeat the tx, but thats requires a bit of hacking as it is not supported by default…

maybe you can help next person, by disable the possibility of use z_addrresses in your interface.

Yes is already implemented. will be in next release. also a info popup when u set up the account.

Ok. Now I have 16 confirmations and a tick, but my balance still 0 … now ?


Hm… Did you do a withdrawal? If not the available balance should include the tx balance.
You can do following to check if the balance in the wallet is correct:

  • Open the emergency wallet too by cmr+e or cmd+e. there u see the total balance. that must match the available balance + the reserved balance.
  • Click alt+j - that opens a popups where u can copy all the wallet keys/txs. there u should see all unspent txs and total balance. compare if it matches the bitsquare UI wallet data
  • Export the transaction in fund/transactions and open it in a spreadsheet app. make a sum over all amounts it should match with the balance in the wallet.

If anything does not match, it seems that the wallet is corrupted (caused by a bug in the prev. verison). If so you can do 2 things. Shutdown the app, backup and then delete the Bitsquare.spvchain file inside the data dir. Then restart and wait until the network sync is finished (can take a while). after that check again the wallet balance if it is now correct. If not let me know.

I folllowed all your instructions but still with problems… as you can see:

and emerengy wallet also says the same … balance should be 0,1988 but UI says 0,0004

it’s weird

If u dont have open offers/trades and disputes u can simply do the withdrawal form the emergency wallet and then backup and delete the data dir and start with a new one. Might be that the bug from the prev. version is the reason.

I try to do it but I’m getting error: Duplicate entrypoint

Also note that this (4.9.8) is first time I install bitsquare

Will send u a PM

please… lupa at