Restoring the wallet after forgetting the password

First: Bitsqare rocks! I tried and used it last month and it worked perfectly well. I also like all the information given right in the program! Good job!.
But now I have a problem. I forgot my password with which I encrypted my Bitsqare wallet. When I now hit “forgot password”, I can enter my wallet seed and the creation date of the wallet.
As soon as I enter the right data it warns me because my wallet is not empty. And it says I shall go to the funds section and withdraw my bitcoins first. But how am I supposed to do that, when I can’t access it without the password?

So I installed Bitsqare on another computer. I wanted to recover my wallet there. But when I enter the exact same data (Seed + creation date) I cant proceed. The “restore wallet” button just stays greyed out

The warning also suggests to use the emergency tool to empty my wallet. What exactly does “empty” here mean? I want to withdraw the money, not empty it and have no access anymore…
And what exactly does happen if I hit “I want to restore anyway”?

So basically I forgot my password. But as I still have my seed and creation date I think it should be possible to gain access again. So what’s the best way to handle this situation?

Thanks for help! It’s much appreciated.

Thanks for your feedback!
I think the problem is that the creation date is not the date from the original wallet but from the newly created wallet. That is not intuitive and I would love to remove that at all but is is part of BitcoinJ.
So the restore button should become active as soon you choose the creation date of the new wallet.
If that does not work ping me an email (u find it at webpage/contact).

Ok, my wallet now restored successfully at the other computer. BUT there is no data in there. There are no funds to withdraw! You wrote in another post: “If you want to move your Bitsquare app to another computer, you need to
backup the data dir first (Account/Backup) and then use that backup and copy it to the other computer (same location)”

My question is: where do I find that “data dir”? Does it only exist when I made a backup first? Now that I can’t access it anymore, I guess there is no possibility to make that backup, isn’t it?

I’m on linux and the only path to some bitsquare files I could find was under “/opt/Bitsquare/” but this looks more like porgramme files and not user data…


If you go to account/backup there is a button to open the data dir, but you can backup directly there the data dir. to get all data u need to copy the complete data dir. With the wallet seed you only restore the wallet and get it in an unencrypted state again. So if u copy over the data dir you will have the encrypted wallet againt there, but just replace it with the restored wallet and all should be ok.

Ok, copying those files worked. Now it’s exactly the same on both of my computers. There is still this warning:

So with “just replace it with the restored wallet and all should be ok” you mean I should hit “I want to restore anyway” and ignore the warning? And what is the emergency tool? I don’t really understand what “empty” here means. Does it mean I get the chance to withdraw my bitcoins or does it delete the data so that I end up with an empty wallet where I don’t have access to my funds?
Sorry for being maybe ultra scared, but I want to be really sure of what I am doing. I’m a student and 1 btc (which is in that wallet) is qite some money for me and I don’t want to loose it.

Thanks in advance, Johannes

No worry better ask twice in doubt!

Yes you can ignore the warning (that is meant if you restore with another wallet, but u use the same), you also have now a backup, so all should be safe. When you restore the wallet over the old wallet the date need to be set to the old wallets date.

The emergency tool is just for emptying the wallet completely (withdrawing all the btc to an address u define). You don’t need that as your new wallet is the same as the old.

After restoring you need to restart. If the wallet balance is not displayed correctly afterwards, please go to the app data dir and remove the Bitsquare.spvchain file:
It is here:
Then restart and after the wallet has synced with the network all should be correct.

Please let me know if the spvchain removal was needed, if so I will do the delete automatically in the next release.

The wallet was restored successfuly after hitting “I want to restore anyway”. After the restart there were still no funds available. So I deleted the “Bitsquare.spvchain” and restarted Bitsquare again. And again. And still no luck. But then on the third restart it took a bit longer to start up and it worked! My funds are there!

Unfortunately I can’t really say if it helped to delete the “Bitsquare.spvchain”.

Thank you so much!

Correct me if I’m wrong.
This means, that if your harddrive dies or your laptop gets stolen, there is no chance to restore your Bitsquare wallet if you don’t have the backupdata, or is there? That’s something that I wasn’t aware of. I mean I have also a electrum wallet and I know, if my computer dies I just use another one, install electrum and enter my seed and voila, my wallet is restored. Would this be the case, where I have to use the emergency tool? Maybe the information texts could be a bit clearer on those issues. Other then that: AWESOME SOFTWARE!

Ok, need to look into that issue why the balance is nto updated the first time correctly.

No, if you have the seedwords backed up or done a backup you are fine. If you only have the seed words but not the data dir backed up then you cannot continue to use Bitsquare as before (if you have offers, trades open…) but you always get out your funds with the emergency tool.

I will try to make that clearer for the next version.
Thanks for your feedback!

Btw.: I just released a new version. Update is highly recommended as there are many bugfixes.